Jump to content

(SOLVED) 9 Disks Marked Unmountable: No File System


Recommended Posts

Hi All,

 

I am having another problem with my system I hope I can get some help with.  Currently I am on Unraid v6.8.3 (Nvidia Edition) and I have been waiting to finish my new backup system before updating to v6.9.  I have purchased 10 14TB hard drives and was in the process of pre-clearing them.  I have 12 8TB drives in my main case and 13 8TB drives in an external DAS case. In order to preclear then new 14TB drives I added a second DAS, daisy chained to the first one. I found that the limitations of my DAS cases are around 1,062MB/s and preclearing the drives would have taken forever.  400+ Hours plus half my array would be bottlenecked.

 

So, I ordered a two port SFF-8088 LSI HBA to run one DAS case on each port.  While I was waiting for the card to arrive, I ran preclears on 4 of the 14TB drives and paused the rest.  My Idea was, I would preclear some, then pause the preclear, shutdown the system, add the new card, start the system back and resume preclearing with more bandwidth.

 

When the card arrived, I popped it into my system and started it back up. All my drives showed up and the configuration was valid, so I started the array.  Immediately I received a bunch of notifications in my browser about CRC Errors, when the page completed loading several of my drives were listed as Unmountable: No File System and my parity drive had an error.  I stopped the array.  I shut down the system, pulled the second DAS off and restarted the computer.  I started the array in Maintenance mode and other than a red X on the parity drive, things look ok.  I tried to start the array normally and it failed again with the same error.  I am attaching a screenshot of my array, my diagnostic file and my syslog. I also downloaded all my drives SMART reports if needed.  What should my next steps be, I hope I did not just Bork the data on 9 drives, that would be a really bad day.

 

Main Array

  • 1  12TB Parity Drive
  • 23  8TB Data Drives
  • 1  8TB Cache Drive

Unassigned Devices

  • 3 Drives in Unassigned Devices (Various Appdata Folders)
  • 10  14TB Drives

 

 

 

-Alex

Screen shot of array.PNG

alex.vision-diagnostics-20210327-1509.zip alex.vision-syslog-20210327-2208.zip

Edited by Alex.vision
update solved
Link to comment

Disks are not mounting because of read errors:


 

Mar 27 15:05:58 Media kernel: md: disk13 read error, sector=8590653888
Mar 27 15:05:58 Media kernel: md: disk13 read error, sector=8590653896
Mar 27 15:05:58 Media kernel: md: disk13 read error, sector=8590653904
...
Mar 27 15:05:58 Media kernel: md: disk14 read error, sector=8590548952
Mar 27 15:05:58 Media kernel: md: disk14 read error, sector=8590548960
Mar 27 15:05:58 Media kernel: md: disk14 read error, sector=8590548968
..
Mar 27 15:05:59 Media kernel: md: disk16 read error, sector=8592953024
Mar 27 15:05:59 Media kernel: md: disk16 read error, sector=8592953032
Mar 27 15:05:59 Media kernel: md: disk16 read error, sector=8592953040

 

etc, check what they have in common, controller, expander, etc, there's likely a problem with one of those.

  • Thanks 1
Link to comment

They all are in the same direct attach storage case with the same backplane on the same controller. I have 2 SGI Rackable 3U 16 Bay SE3016 SAS Expander Chassis. I had them daisy chained to each because I only had a single port card in my computer. I discovered while trying to preclear some new drives that they were severely bottlenecked. When I realized it would take forever I got a two port card and moved each SE3016 to its own port.  For some reason when I started the array I got those errors. Now I have 9 drives that had some kind of issue. I don't think there is anything wrong with them, I think they had some communication issue when I moved to the new HBA card. They had been working for a couple of weeks daisy chained together and the unit with my main array drives has worked for years on the old single port HBA card. It wasn't until I moved to the new card that I had trouble.

 

Now I'm trying to understand what I should do to move forward and get these drives back online. I can put the old HBA card back in but wont the drives still be Unmountable?

Link to comment
  • Alex.vision changed the title to (SOLVED) 9 Disks Marked Unmountable: No File System

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...