Jump to content

SWAG Reverse Proxy - Unifi - Certificate Signing Failure - Unraid 6.9.1 (SOLVED)


Recommended Posts

Hi All,

 

First things first, I am very *very* new to Unraid so please be patient. I have a trial version of Unraid installed and I am planning on using it to replace my synology nas (and use the synology as the backup for unraid).

 

I've attempted to find a solution to an issue I am having but my googlefu appears to be lacking on this one.

 

The issue that I am having is with trying to setup DDNS and SSL with SWAG. I have followed spaceinvaderone's tutorial on how to set up LetsEncrypt (which I belive has been replaced by swag, and the setup looks the same) but I can't seem to get the certs signed. My domain name provider has its own DDNS service and I have this working and it is updating every 5 mins. Other than a change in DDNS provider I have followed this tutorial as best I could:

 

Attached is my firewall settings and port forwarding rules along with the error's being generated by swag. I have redacted the root domain, IP's ect for privacy and security.

 

My network is based on UniFi by Ubiquity if that helps as well. (I also have an issue where DLNA isn't working with UniFi, JellyFin, and Google(YouTube Control), but I'm assuming that is more a question for the Ubiquity forums question ... unless you guys have some tips).

 

I hope to hear from you guys soon, and thanks in advance for all your help.

 

Rattus.

 

UniFi Port Forward Rules Reverse Proxy.PNG

swag certificate generation fail.PNG

UniFi Firewall Rules Reverse Proxy.PNG

Edited by Rattus
Solved - Marked Solved
Link to comment

 

The log says that the ssl certs are not being created as it cant verify the subdomains. You are using http verification, so it checks using the subdomain ie radoncloud.yourdomain.com is resolving back to swag through port 80.

So this is not happening. I can see you have set up a port forwarding rule, but some isps block port 80 on home connections. I would suggest moving your domain to cloudflare then using dns verification rather than http

See this video here for how to add your domain to cloudflare https://youtu.be/y4UdsDULZDg

And here for how to setup dns verification with cloudflare and letsencrypt (swag)   https://youtu.be/AS0HydTEuA4

 

Link to comment

Hey Spaceinvader,

 

Thanks for the assist. Yes as it turns out my ISP does block port 80 and 443 by default. Good News, It can be disabled easily and it works perfectly now ... sorta. I might have to make a new post about OnlyOffice document server if I can't figure that one out. But Swag has now sorted itself out so thanks a heap!

 

Thanks again mate, and I'm looking forward to the new 6.9.x videos.

 

Rattus

Link to comment
  • Rattus changed the title to SWAG Reverse Proxy - Unifi - Certificate Signing Failure - Unraid 6.9.1 (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...