Jump to content

(SOLVED) Unraid 6.9.2 - Two disks read failed

Recommended Posts

I have two disks in my array and my data disk has been disabled with a red X. I did also receive a notification that both drives (data and parity) have read failures (diagnostics-20210415).


A few days ago, I've had a similar issue with just the data disk getting write failures and being disabled (diagnostics-20210413). I rebuilt that disk from parity and a couple days later the above issue happened with two disks. Now, I've also had problems in the past with the cache drive being unmountable and either I had to restore from backups, or managed to successfully run xfs_repair.


For that reason, I suspect a fault with my SATA controller. Can the smart people of the forums confirm this with diagnostics attached or have any other ideas of the possible causes?

sushi-diagnostics-20210415-0858.zip sushi-diagnostics-20210413-1903.zip

Edited by kabloomy
Marked as solved
Link to comment

Thanks, I did some googling and I found someone similar issues and their conclusion was power also.


I do have a 2-way Molex power splitter splitting the SATA fan-out power with a fan controller from Aliexpress. So it could be either of those causing issues. I've disconnected the fan controller for now and will monitor for further problems.

  • Like 1
Link to comment
  • kabloomy changed the title to (SOLVED) Unraid 6.9.2 - Two disks read failed

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...