No Shares showing - but all can be access directly

Recommended Posts

Running 6.9.2


Usually when pointing a file browser at smb://10.0.10.x all my shares are listed.  I can click a share and view its files.

Presently when pointing a file browser at the IP of unRaid, I'm getting 0 items.  It doesn't time out or give an error, it just shows nothing.

Happening on Linux & Windows computers.


However all machines (Windows, Linux & Android) are able to access the individual shares.  e.g. smb://10.0.10.x/share works fine.  I can read, write, access files as normal.


So where has the share list gone? 


The only config change I am aware of making has been SMB -> WSD options.  I was trying to deal with the 100% CPU issue.

I initially added the -i br0 argument, but still had issues.  Everything worked as normal for a while.  Then CPU usage spiked again, so I disabled wsd.  NETBIOS is also turned off. 


I tried resetting these, restarting samba and bringing the array back online, but still had the same issue.  So I put it back to SMB enabled with everything else off. 

To stop the 100% CPU from wsd, I would prefer to keep it disabled.  But I also want to be able to view a list of shares on the server!

What is my next step?




Link to comment
On 4/24/2021 at 11:03 AM, Raki72 said:

Hi MediaMaan,


I face exactly the same problem. Did you ever find a solution?


Hello Rali72.


Unfortunately I have not managed to figure it out yet.  I am noticing the problem more on my Linux Mint computers.  Right now my Windows 10 PC can access the share list at the unRAID IP address.  The Linux Mint ones can read the list after a reboot at smb://10.x.x.x, but appear not to be able to show it on subsequent visits via SMB.  The share lsit remains empty.  Typing a share name in directly (smb://10.x.x.x/share) continues to work.


At this stage I'm unsure if it is a Mint issue, or an unRAID issue.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.