Plex: Nicht außerhalb deines Netzwerks verfügbar


Recommended Posts

Ich versuche gerade Plex mit meiner eigenen Domain ausschließlich über https erreichbar zu machen. Das funktioniert auch, aber Plex behauptet steif und fest, dass es nicht von außen erreichbar sei:

image.png.ccbb95861303742deca64ec582ce4cbe.png

 

Kommen wir mal zum grundlegenden Aufbau. In meinem Router ist der Port 80 und 443 auf die IP 192.168.178.8 freigegeben:

image.png.96b4bd08e95634371046139390546d0f.png

 

.8 ist in dem Fall der Nginx Proxy Manager:

image.png.4b2b202c932d2bbc5c9c36c9d46560e1.png

 

In NPM wird der eingehende Traffic auf https://plex.example.com an 172.19.0.2:32400 weitergeleitet:

image.png.a718cab258b1929c4417b364b72cfa91.png

 

Was wiederum Plex ist:

image.png.774ff3d512411d7e982f03f927ae966b.png

 

Damit der Zugriff lokal und extern funktioniert, musste ich "Eigene URLs für den Zugriff auf diesen Server" festlegen:

image.png.6b6fc44ba2f18527d2ff783b92b84323.png

 

Wenn ich nun lokal im Browser ein Video starte, dann sehe ich im Netzwerkmonitor, dass er das Video von der folgenden Domain lädt:

https://192-168-178-9.123456.plex.direct:32400/

 

Diese Domain löst auf die lokale IP 192.168.178.9 auf:

ping 192-168-178-9.123456.plex.direct

Ping wird ausgeführt für 192-168-178-9.123456.plex.direct [192.168.178.9] mit 32 Bytes Daten:
Antwort von 192.168.178.9: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.178.9: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.178.9: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.178.9: Bytes=32 Zeit<1ms TTL=64

Ping-Statistik für 192.168.178.9:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms

 

Damit das überhaupt geht, musste ich den Rebind-Schutz für plex.direct aufheben:

image.png.23f55e035ecc78c74f49b314f279f7a2.png

 

Dann habe ich bei meinem Handy einen Hotspot erstellt und das selbe mit einem Notebook wiederholt, um zu testen wie der Zugriff von außen erfolgt und da lädt er die Videos über diese Domain (er nutzt also den https Port 443):

https://plex.example.com/

 

Also alles genauso wie ich es gerne hätte.

 

Da der Traffic von außen ja über Port 443 reinkommt, habe ich beim Plex Fernzugriff genau diesen Port hinterlegt:

image.png.396fd3dd8961a37788aea49ee01061db.png

 

Das einzige was sein könnte, dass Plex nicht über https://plex.example.com den Fernzugriff testet, sondern über https://73.77.99.34/ oder gar http://73.77.99.34:443 ?! Das wäre dann aber in meinen Augen ein Bug. Hat jemand eine Idee wie ich das prüfen könnte?

 

Hier das Ergebnis, wenn ich von außen auf die IPs zugreife:

 

http:

1204172503_2021-06-2813_47_00.thumb.png.37978bb1a1243e4f57823ff21369b859.png

 

https:

857137078_2021-06-2813_47_09.png.a104cd9a1ec497c26a0c512352064b51.png

 

 

 

Link to comment

Ok, das ist jetzt komisch. Wenn ich in NPM einen Stream Host hinzufüge und Port 443 auf 32400 weiterleite:

1016154489_2021-06-2813_51_21.png.b856a814f6da92acef457ddb6449a3a2.png

 

Dann sagt Plex, dass es von außen erreichbar sei:

image.png.a1a12992ba3b2cbccd7a44825709b121.png

 

Man muss dazu wissen, dass Stream Hosts wirklich alles auf diesem Port weiterleiten. Es wird also nicht mehr an Hand einer bestimmten Domain ein Reverse Proxy genutzt, sondern der ganze Traffic wird einfach auf den 32400 genatet. Damit werden alle Filter und auch das SSL Zertifikat ausgehebelt, weshalb das natürilch keine Option für mich ist.

 

Ich habe natürlich auch wieder von außen getestet und ein Zugriff über https://73.77.99.34/ ist nach wie vor nicht möglich. Plex scheint also nicht über die öffentliche IP auf den Server zugreifen zu wollen, sondern ich vermute über eine eigene Domain. Kann das sein? Eventuell über etwas wie 73-77-99-34.123456.plex.direct?! Keine Ahnung wie ich das herausfinden könnte. 🤔

 

Link to comment

Leider akzeptiert NPM keine Wildcard bei der Domain, sonst könnte ich einfach alle Zugriffe von außen auf plex.direct ebenfalls durchleiten:

 

786386078_2021-06-2814_04_00.png.4c46a050434f56a354bdd9135d36fa6d.png

 

Auch eine entsprechende Advanced Configuration hilft nicht:

image.png.251e92a534ca63ec79a5c84e067b8455.png

 

Wobei ich ja wie gesagt nicht mal weiß ob Plex über diese Domain prüft. Gibt es noch andere Domains, die Plex nutzen könnte?

 

Ich weiß, dass es eigentlich egal ist, da es ja funktioniert, aber das macht mich ganz wuschig, dass der das nicht anzeigt ^^

 

Link to comment

Also die Advanced Configuration funktioniert auf jeden Fall. Ich habe eine weitere Subdomain nas.example.com mit einem CNAME auf die Hauptdomain plex.example.com erstellt und wenn ich in der Configuration diese Domain hinterlege, dann wird ebenfalls Plex geladen

 

image.png.75b507de1d3ca056a84d30f9897d78d2.png

 

Dann gehe ich auch mal davon aus, dass "*.plex.direct" gehen sollte.

Link to comment

Ok sauber. Problem gelöst. Plex geht hin und testet den Zugriff von außen über die Domain https://plex.tv was mal gar keinen Sinn macht, weil diese Domain natürlich nicht auf meine öffentliche IP auflösen sollte, sondern auf die IP der Plex Website. Das heißt sie überschreiben beim Test die IP dieser Domain.

 

Nachdem ich nämlich "plex.tv" als weitere Reverse Proxy Domain hinzugefügt habe:

image.png.6f10550c7c37e0a1cfeb9ad23dbaf41a.png

 

Zeigt Plex einen gültigen Fernzugriff an:

image.png.6cda37615f6a7ca8f9bba7980810200e.png

 

Darauf muss man erst mal kommen.

Link to comment
  • 4 weeks later...

Auch wenn ich "ein bisschen" spät zur Party bin, ich habe das gelöst indem ich einfach den "Fernzugriff" in Plex deaktiviert habe. Hört sich unlogisch an, ist aber so. Dadurch benutzt Plex nicht mehr was Plex nutzen will und ich kann ganz normal über meine eigene Domain, Port 443 und npm (Proxy Host, https://interneIP:32400 ) gehen. Ohne weitere Eintragungen, ohne zusätzliche Parameter oder ähnliches.

Da ich die Domain, wie Du, in Plex über Netzwerk -> "Eigene URLs für den Zugriff auf diesen Server" propagiert habe (allerdings ohne Leerzeichen nach dem "," - kA, ob das einen Unterschied macht), funktioniert trotzdem noch der Zugriff über plex.tv, obwohl "Fernzugriff" deaktiviert ist.

Link to comment
2 hours ago, Torben said:

ich habe das gelöst indem ich einfach den "Fernzugriff" in Plex deaktiviert habe

Habe ich mittlerweile auch gemacht, denn Plex "spinnt" bei dem Menüpunkt einfach nur herum. Manchmal kommt nämlich trotzdem ein Fehler, obwohl das gar nicht sein kann.

 

Ich habe es jetzt übrigens auch endlich voll IPv6-fähig umgesetzt. Das war eine Geburt sage ich dir. Muss ich auch noch einen Guide für machen 🙈

Link to comment
1 hour ago, mgutt said:

denn Plex "spinnt" bei dem Menüpunkt einfach nur herum

Hatte ich auch gedacht, nachdem ich mehrere Stunden meinen vermeintlichen Konfigurationsfehler gesucht hatte. Ist meiner Meinung nach in Plex hart verdrahtet bei Nutzung des "Fernzugriff", man kann nur den Port der Website ändern (was auch immer einem das bringen soll). Wobei ich nicht mal sicher bin, ob ich das Ganze über plex.tv probiert hatte, vielleicht schleust er es dann komplett über den angegebenen Port? Wie auch immer...ich nenne sowas bei Plex gerne: "Das hat Bernd vor 10 Jahren programmiert, wir wissen nicht was es tut und hängen nur Code dran." Die Datenbank ist dafür auch ein gutes Beispiel...sieht eigentlich logisch aus, bis man was ändert und gaaaanz komische Dinge passieren. ;-) 

 

1 hour ago, mgutt said:

Ich habe es jetzt übrigens auch endlich voll IPv6-fähig umgesetzt.

Das ist cool. Wollte ich auch probieren, als an meinem verwandtschaftlichen Server-Standort FTTH gelegt wurde...aber dann lief mir die Zeit davon und ich habe halt doch wieder 'ne IPv4 beantragt (für 5 Euro/Monat, ich dachte ich lese nicht richtig). Irgendwann setze ich mich in "urlaubiger Ruhe" nochmal dran, vielleicht ist Dein Guide ja dann schon draußen. 🙂 

  • Haha 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.