Jump to content

Need some help - Cannot stop array that is currently in 'Maintenance Mode'


acez7

Recommended Posts

Hello all. Its not fun being stuck in Unraid limbo, as we all know. Maybe there is an easy workaround/solution that I am just not seeing.

 

Let me explain.  I have attached a diagnostics file and a syslog.

 

 

=================================================================================================================

 

  • Initially I shrunk an array of 2 disks to one disk. That disk was taken out last week and currently in use in a whole different project. I had moved all my data to Disk 1 using krusader, prior to removing Disk 2.
    • image.png.d3e6599853d4b62c5d0c8921d9c6c1bf.png

 

  • After that I did not know how to get rid of Disk 2 from Unraid config. I tried the following while array was in maintenance mode. image.thumb.png.8131374607cdac4225ec79ac8a4324cf.png
    • This did not change anything on GUI ( I still have that Disk 2 with a red X mark under array devices.
  • The main issue now is that I cannot stop the array (just hangs and does nothing) . Now stuck in 'Maintenance Mode' and not sure what to do next.
    • image.thumb.png.0cda585d6f3d7516dfd6cdff4e9fd970.png

 

  • Lastly this is also pretty concerning. Not sure if i should be seeing this when i click on 'Shares' while in maint. mode. 
    • image.thumb.png.7ab6ed0b48c82d6ecafe8dcfeb6b7627.png

 

==========================================================================================================================

 

 

How should I proceed? I have a backup USB settings file somewhere but that is over 3 weeks old and would rather not go down that road unless absolutely necessary.

 

Thanks for reading and have a good rest of your day.

 

Edited by acez7
security
Link to comment

Good point! I completely overlooked that function in Unraid.  I will have to do that once I can officially stop this array. A reboot or shudown 'feels' risky though at this point.

 

I was able to run a 'Flash backup' just right now but unsure if that will even be helpful if I were to reboot.  How risky is it to restore from a flash backup that is much older and has the Disk 2 info ?

 

I tried enabling SSH from management access but that is not going either.

Link to comment

Real-time logging appears to be disabled while in Maintenance mode..?

image.png.64956e36af00a3bb6b29535fe75aa394.png

 

Additionally:

 

image.png.e41f76aaa1fb57847d03f9ee4ac1952b.png

 

I cannot run a parity check (Read-Check) in this current mode. Any way to force a parity check without SSH working?

Edited by acez7
adding on info
Link to comment
1 hour ago, acez7 said:

How risky is it to restore from a flash backup that is much older and has the Disk 2 info ?

As far as Unraid is concerned, there is still a disk2 in your array, even if the disk has been removed and smashed with a hammer. It is emulating the disk from the parity calculation by reading parity and all other disks.

Link to comment

You can't do a parity check because you have a disabled disk. Why do you want to do a read check?

 

How did you get that "Erase Device Content"? I assume it was something on the Disk2 settings page shown behind it. Were you trying to change the filesystem? Only wonder because I don't know how you got hung up there.

 

2 hours ago, acez7 said:

shrunk an array of 2 disks to one disk. That disk was taken out last week

You haven't shrunk the array until you get a configuration without disk 2 and with parity rebuilt. You have had no parity protection ever since that disk was removed.

 

I don't think there is much risk to using the power button. No disks are mounted in Maintenance mode. You are going to be rebuilding parity anyway. Go to Settings - Disk Settings and disable autostart. Then when you restart you can go immediately to New Config

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...