Jump to content

Missing OS after update from 6.9.1 to 6.9.2


Blueeye

Recommended Posts

Dear all,

 

I just tried to update my server from 6.9.1 to 6.9.2 via the web interface. Unfortunatley, the system is now not booting anymore. I have to confess that I'm not a Linux pro and I have concerns to face data loss and (what will likely anyhow be the case) my server settings.

 

- Unraid was installed on a USB stick

- System is not recognizing the stick after boot as bootable device containing an OS (Missing OS notification)

- I've tried via the boot manager to manually select the USB stick (in case of a potential issue with the installed HDDs), with no luck. All I can do is hit a key to reboot the system.

 

My questions would be:

- Any advice how to try to recover what might be still left on the stick, e.g. server settings? Any specific files I should try to extract, if possible?

- How save is it to reinstall Unraid (fresh install) to the stick and then reinitiate the HDDs (Raid 5, 4 disks with 1 parity drive)? Is this usually no problem or do I need to take care of specific settings?

 

Sorry for the rookie questions, but as said my experience is limited with Linux.

 

Thanks for your time and help.

 

Blueeye

Link to comment

Do you have a recent backup of the Unraid flash?  
 

If you do then switching to a new flash drive with all settings is easy  

 

If not then this section of the online documentation has a process for getting back your dtive assignments

 

Your data will be intact regardless, but if you have no backup you will probably have to set up plugins/docker containers/VMs again.

Link to comment

Unfortunately I'm stupid enough to not have a backup of the flash drive. I just used a recovery software to check if there is still something on the flash drive - yes it is, but most of the data on it is corrupted. Something must have went horribly wrong during the 6.9.2 update process.......

 

What I currently do is to manually copy the content of my HDDs to additional offline HDDs just to be sure to avoid data loss using a Ubuntu stick (data can still be accessed, thank god). Next step will be to get the RAID back online with a new usb stick, thanks a lot for your guide linked above.

Link to comment
6 hours ago, Blueeye said:

(Raid 5, 4 disks with 1 parity drive)

Unraid IS NOT RAID

 

3 hours ago, Blueeye said:

Unfortunately, the whole flash drive is not working any longer -.- I can't access anything. Tried it via Ubuntu and several Linux readers for Windows...

The flash drive is FAT32, a Windows filesystem. Put it in your PC and let it checkdisk.

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...