Jump to content

VM Tab slow loadtime.


Recommended Posts

I noticed a lot of my calls to VM related actions have gotten pretty slow.

After pressing the button to the overview of VMs, the call to the "VMs" endpoint takes 6.5s to load, and additonally the call to "plugins/dynamix.vm.manager/include/VMMachines.php" takes 7.7s to load. So that's 14 seconds, just to display the single VM I have configured.


When I try to create a new VM, the call to "AddVM" takes 7s according to my browser.

"UpdateVM" actually seem to be the fastest at 5.7s.

I don't recall it being this slow before, so something might have changed.


According to Firefox, the majority of the request time is in "Receiving":

Load time

I have tried another browser, which didn't make a difference and I tried deleting the libvirt.img as well.

Finally, I have tried making curl requests from the unRAID server to itself, to exclude the possibility of network issues and the results were consistent with the slow load times.


I have no idea where to go next, so any help is much appreciated.


Edited by diskplace
Solved the issue.
Link to comment

I somehow managed to fix this.

The issue still persisted this morning, but I removed "dynamix.s3.sleep.plg" and "preclear.disk.plg", because I was no longer using them.

After the removal, the issue was gone right away and load speed for the VM actions is now around 250ms.


I am not sure, if this is a one-off problem or even related to the two plugins. But for now, it seem to work.

Reinstalling the two plugins, does not seem to trigger the issue again.

Link to comment
  • diskplace changed the title to [Solved] VM Tab slow loadtime.
  • diskplace changed the title to VM Tab slow loadtime.
  • 7 months later...

This is happening to me (sometimes, it will just time out and I never get the tab to complete loading, left with a blank table). This started after I had my cache disks both die on me at the same time, wiping out existing VMs and libvirt. I got new cache drives in, got moved back onto cache drives, rebuilt new VMs from scratch (as I lost the img from before). 


When it timesout, I receive ERR_HTTP2_PROTOCOL_ERROR. I can refresh a few more times, and eventually, I will get the tab to load where I can manage my VMs via GUI again. 


I've made sure that everything is back on the SSD cache drives, and nothing is on spinning disk (including libvirt). 


Does feel like an issue with loading libvirt, as once I can eventually get it to load the VM tab, it will refresh normally with no issue for some time until the VM tab hasn't been accessed for a while. 





Edited by jslay
Link to comment
  • 1 year later...

@SimonF is correct in regards to having referenced isos from array having to spin up the disk before tab loads. The Fix: I edited all my windows VMs and removed the reference to the virt-io.iso which i have stored on array. And now the VM tab loads fast as normal. I never noticed this in the past because i kept my isos directory on cache but i moved it to array to clear up cache pool, and thats when this started happening.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...