Jump to content

Erreurs sur Array


Recommended Posts

Je ne suis pas un expert des attributs SMART.

Mais de ce que j'ai lu sur les forums, dans ta situation je ne garderai pas ces deux disques :

  • pour le disque 5, il y a bien sûr les attributs 197 et 198 qui ne sont pas super rassurants. Mais surtout l'attribut 1 qui est aussi non nul. Par défaut Unraid ne le surveille pas (comme l'attribut 200) parce que différents fabricants le gèrent différemment. Sur un disque WD, ce sont des attributs qui devraient rester à 0 (contrairement aux Seagate).
  • pour le disque de parité, l'attribut me fait un peu peur mais je n'ai pas trop de recul dessus. Je me dis tout de même que si Unraid le surveille, ce n'est pas pour rien ?

 

Je ne sais pas si d'autres personnes ici ont une plus grande expertise dans le domaine ?

Au pire tu peux demande confirmation dans la partie anglophone, dans la section Storage devices and controller par exemple.

 

Pour tes autres disques WD pas de soucis pour le moment, mais je te conseille d'ajouter les attributs 1 et 200 dans les éléments surveillés par le système pour être alerté au plus tôt en cas de changement.

Dans l'onglet Principal, clique sur le disque et ajoute 1,200 dans le champ notification puis Appliquer

image.thumb.png.4c7c66ecbfcdccc458914a5305fde525.png

 

N'hésite pas si tu veux des conseils pour la suite.

Link to comment

J'ai pris des vieux disques, je ne suis pas étonnés qu'ils tombent. J'ai mis la surveillance des 1 et 200 mais le paramètre ne reste pas affiché dans la case est ce normal ? je pense qu'ils sont pris en compte vu que j'ai maintenant le hd 3 qui est en orange ...

 

Je poste qu'ici car mon niveau d'anglais est inférieur à un gamin sortie de primaire 🥴alors sur du technique que je ne maitrise pas, le dialogue sera quasi impossible. 

 

Je dois lancer un test smart sur chaque disque ou la surveillance suffit ?

Link to comment
2 hours ago, Crashbird said:

J'ai mis la surveillance des 1 et 200 mais le paramètre ne reste pas affiché dans la case est ce normal ?

Ca me fait ça aussi dans l'interface, mais je suis allé vérifié sur le fichier smart-one.cfg dans le dossier /config de la clé USB et ça semble bien enregistré.

 

2 hours ago, Crashbird said:

Je dois lancer un test smart sur chaque disque ou la surveillance suffit ?

Je pense qu'en temps normal la surveillance devrait suffire, mais ça ne mange pas de pain de faire une petite vérif avec un test étendu, surtout si tes disques sont anciens.

 

Je verrai si je peux faire un message demain dans la partie anglophone pour toi pour en avoir le cœur net. Mais je suis en réunion une bonne partie de la journée, je ne sais pas quand je pourrais.

 

Si ça se confirme, il te faudra réorganiser ton Array parce qu'avec un disque de donnée et le disque de parité suspicieux, ta protection en cas de panne n'est pas géniale.

L'avantage c'est que tes données semblent être sur tes disques 1 et 2 qui sont en bonne santé.

Link to comment

JorgeB a qui je fais confiance sur ce genre de chose a regardé ça.

Quote

WD should be fine as long as raw read error rate doesn't keep climbing, user should monitor that attribut, pending sector is a false positive since SMART test passed, Seagate is more difficult to say, that attribute it to high for my liking, disk should be OK for now but I would replace it when possible.

Pour le disque 5, ça peut être OK pour le moment puisque le test SMART étendu est jugé OK. Il faut par contre que tu "acceptes" le défaut sur le tableau de bord. Je ne l'ai jamais fait, n'ayant jamais eu de soucis sur mes disques pour le moment. Je crois qu'il faut cliquer sur le pouce vers le bas et qu'un menu apparait.

Comme ça, Unraid va continuer à surveiller t'alerter vu que tu as ajouté la surveillance des attributs 1 et 200.

 

Pour le disque de parité par contre, il faudrait le retirer et le remplacer.

 

On peut discuter des options pour arriver à ce que tu souhaites en fonction de ce que tu as pour le moment.

Link to comment

Je vais recevoir mon disque de parité cette semaine. J'ai des erreurs SMART 1 Raw read error rate sur les disques 3 et 5 ... je préfère les changer également. J4ai essayé d'en changer un voici ma procédure

- je désactive l'array

- je dé-assigne le disque

- j'arrête le NAS

- Je monte le disque de remplacement

- J'allume

 

Et là rien, Unraid ne se lance pas. Quand je remet le disque originel ça se relance sans problème. Bien entendu je n'essaye de changer d'un disque à la fois. 

Link to comment

Salut, peux tu clarifier 

9 hours ago, Crashbird said:

Unraid ne se lance pas.

 

L'OS ne démarre pas ou il démarre mais n'arrive pas à reconstruire/démarrer l'array/autre soucis ?

 

Dans le premier cas, je pense qu'il y a probablement un soucis de sélection du disque de démarrage au boot. A voir dans le BIOS si tu peux jouer sur les préférences de boot (jamais SATA par exemple) pour éviter le soucis.

Si c'est le second cas, il me faudrait plus de détails pour te proposer des trucs.

 

Dans tous les cas, la procédure pour remplacer un disque se trouve ici.

https://wiki.unraid.net/Replacing_a_Data_Drive

 

Après dans ton cas, si tu veux remplacer la majorité des disques il faut voir si c'est la meilleur méthode niveau temps (et si tu as des sauvegardes de ces données).

Link to comment
6 minutes ago, Crashbird said:

Cela me permet aussi de manipuler un peu l'OS

Ca va surtout faire du temps de reconstruction pour chaque disque changé, si tu les change tous ça va faire long. ;) 

 

Selon comment c'est rempli, on doit pouvoir faire un peu plus rapide je pense.

 

Si tu peux me faire un imprim écran de l'onglet Principal où on voit tous les disques, j'aurais une meilleure compréhension des disques pleins/vides et le redire quels disques tu veux remplacer.

Link to comment

Ok, bonne nouvelle pour le boot. :)

 

Si tu n'as des données que sur 1 et 2 et que tu vas devoir reconstruire ta parité de toute façon, je pense que le plus simple et le plus rapide est de tout faire en une seule fois.

 

Tu as les numéros de série des disques que tu veux garder sur l'imprim écran pour ne pas faire d'erreur.

 

A ta place je ferrais :

  • arrêter le serveur, retirer les disques à remplacer
  • mettre les nouveaux - bien vérifier les connexions puissance et données ; des deux côtés
  • démarrer le serveur - il devrait ne pas être content ;) - arrêter l'Array si nécessaire mais je ne pense pas qu'il démarre avec 3 disques manquants
  • Aller dans Outils / Nouvelle config
    • sélectionner conserver tous les assignements
    • Terminer en cochant la case
    • image.png.79dfdc11ea887a979985bf2fb62fd477.png  image.png.5b29a7a1bcef25808daf7645a7f4d7f2.png
  • Retourne sur Principal
  • retire/remplace les disques à volonté (attention à ne pas mettre les disques 1/2 sur Parité, ils seront effacés)
  • /!\ Vérifie bien que les bons disques sont dans le bon emplacement (l'impr écran de plus tôt), Array, Pools /!\
  • Quand tout est bon, va dans le bas de Principal et démarre l'Array (ne coche pas un truc qui dit que la parité est valide, ce n'est pas le cas)

  • Tu dois avoir un popup qui te dit que le disque de parité va être effacé  (là c'est de mémoire, je ne peux pas tester pour voir sur ma machine)

Si tu as le moindre doute pendant la procedure, arrête et demande nous, imprime écran à l'appui.

 

Link to comment
41 minutes ago, Crashbird said:

je suppose que c'est une mauvaise lecture/interprétation de l'attribut 1, et c'est aussi pour cela qu'il n'est pas surveillé à base. Ce sont deux seagete

En effet, Seagate gère cet attribut différemment et les attributs 1 et 200 ne sont a surveiller que sur les Western Digital.

 

Par curiosité, Unraid a laissé cette surveillance tout seul ou tu les avais ajouté toi même ?

Link to comment

Salut,

je ne suis pas vraiment un expert là dessus, de ce que je comprends, les UDMA CRC sont le plus souvent attribués à un soucis de communication pas fiable entre le disque et le système.

Vérifie tes connexions, SATA et puissance, côté disque comme côté CM/Alim. Si possible change de cables. Assure toi de ne pas avoir trop de DDs sur un seul cable d'alim aussi.

 

Il faut que tu Accepte le défaut sur le tableau de bord, vu que le compteur ne redescendra jamais tout seul et que tu continues de surveiller si ça n'augmente pas (ou "Reconnaisse" ? je ne sais pas comment c'est traduit).

 

Le Reported Incorrect, c'est la même valeur que plus haut, même disque ? Il me semblait que tu le changeais ?

Si c'est un différent, essaye de faire un Test SMART étendu pour confirmer. Si c'est confirmé, ce n'est pas bon signe.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...