Jump to content

How do docker permissions work for images from dockerhub: owncloud OCIS


ab5g

Recommended Posts

Hi Guys 

 

This is probably a stupid question but I am having a tough time trying to run a dockerhub image on unraid. The image in question is  owncloud/ocis.

I have the following configuration on unraid

 

PROXY_HTTP_ADDR = 0.0.0.0:9200

OCIS_URL = http://192.168.1.142:9200

Data Path in container /var/tmp/ocis mapped to /mnt/user/OCIS_TEST

 

Instructions from OCIS : https://owncloud.com/news/howto-install-owncloud-infinite-scale-tech-preview/

 

When I run this the I get the following error and the container stops.

It's clearly a permission error and I can't seem to get my head around it.

 

 

{"level":"info","service":"settings","transport":"http","addr":"0.0.0.0:9190","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"ocs","transport":"http","addr":"0.0.0.0:9110","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"idp","transport":"http","addr":"0.0.0.0:9130","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"web","transport":"http","addr":"0.0.0.0:9100","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"ocs","transport":"debug","addr":"0.0.0.0:9114","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"thumbnails","transport":"grpc","addr":"0.0.0.0:9185","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"web","transport":"debug","addr":"0.0.0.0:9104","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"storage","transport":"debug","addr":"0.0.0.0:9179","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"storage","transport":"debug","addr":"0.0.0.0:9149","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"thumbnails","transport":"debug","addr":"0.0.0.0:9189","time":"2021-09-30T09:31:55Z","message":"starting server"}

{"level":"info","service":"storage","time":"2021-09-30T09:31:55Z","message":"host info: 2d529c6a0d7f"}

{"level":"info","service":"storage","time":"2021-09-30T09:31:55Z","message":"running on 20 cpus"}

{"level":"error","service":"storage","error":"open /tmp/revad--059cacdd-d8b0-447c-b931-1c85ec99cda3.pid: permission denied","time":"2021-09-30T09:31:55Z","message":"error creating grace watcher"}

 

The permissions on the directory are 

drwxrwxrwx 1 nobody users   48 Sep 30 16:18 OCIS_TEST/

 

When I run the same container on my machine using docker, the image runs perfectly. 

Any help is appreciated

 

Edited by ab5g
Link to comment
13 hours ago, Squid said:

You can try switching the host reference from /mnt/user/OCIS_TEST to instead be /mnt/cache/OCIS_TEST  

 

Thank you for responding. Umm I do seem to being getting those /tmp related permission errors on a lot of community containers too - owncloud, nextcloud, mariadb. I am on 6.10-RC1. The difference is that those containers do start and I then manually change the permissions on /tmp of the container to 777. I think I have an underlying issue - would you know where to start troubleshooting ?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...