Jump to content
We're Hiring! Full Stack Developer ×

Install unRAID on a QNAP TS-269L (ends with GRUB error)


Recommended Posts

Hello, this is my first post here. I'm an unRAIDER user since some months ago, and I'm very satisfied with my unRAID personal NAS.

 

But, yestarday I was about to try to install unRAID on a QNAP system (TS-269L). It failed, several times.

This is what I have tried so far with no success:

- Creating the bootable USB (2 different USBs: Toshiba 16GB and Kingston 16GB DTSE9) with the official tool (unRAID), and manually using Rufus.

- Switch on/off BIOS Legacy, UEFI Compatibility with different combinations from the NAS BIOS.

- Taking the DOM module out and try to install both NAS OS without it.

- Install both NAS OS to another USB stick connected to another 2.0 available ports, and to a SSD disk also.

 

I read that unRAID requires the user to has, between other things, a minimum of 2GB of RAM (my main server has 32GB, but the QNAP only has 1GB/DDR3 currently, but expadable up to 3GB).  And also, I would like to say that I already tried an alternative NAS OS (sorry for the possible SPAM, but I think it will help): OpenMediaVault (v5 and v6 beta), and didn't work too.

 

The error is about GRUB not being able to access/write to '/dev/sdx'. On both unRAID and OMV fails with the same error.

 

Some users told me, and I also read some posts on internet, that it could be related to the available amount of RAM the NAS currently has. But some other users say: the error may come from the kernel (GRUB) not being able to point and mount the corresponding selected disk for installation (/dev/sdx).

 

I have attached some related useful images to this post. Hope some being in the same situation as me could give me a hand. I'm currently working with QTS but mmm, I would like to come back to unRAID on this NAS hehe. Thank you in advance.

photo_2021-10-01_17-22-12.jpg

photo_2021-10-01_17-38-57.jpg

photo_2021-10-01_18-15-30.jpg

photo_2021-10-02_00-13-46.jpg

Edited by SmartPhoneLover
  • Like 1
Link to comment
40 minutes ago, SmartPhoneLover said:

Demonios, esta es mi primera publicación aquí. Soy usuario de UNRAIDER desde hace algunos meses y estoy muy satisfecho con mi NAS personal de UNRAID.

 

Pero, ayer estuve a punto de intentar instalar unRAID en un sistema QNAP (TS-269L). Falló varias veces.

Esto es lo que he intentado hasta ahora sin éxito:

- Creando el USB de arranque (2 USB diferentes: Toshiba 16GB y Kingston 16GB DTSE9) con la herramienta oficial (unRAID), y manualmente usando Rufus.

- Encienda / apague BIOS Legacy, Compatibilidad UEFI con diferentes combinaciones del BIOS NAS.

- Sacar el módulo DOM e intentar instalar ambos SO NAS con él.

- Instale NAS OS en otra memoria USB conectada a otros puertos 2.0 disponibles y también a un disco SSD.

 

Leí que unRAID requiere que el usuario tenga, entre otras cosas, un mínimo de 2GB de RAM (mi servidor principal tiene 32GB, pero el QNAP solo tiene 1GB / DDR3 actualmente, pero expandible hasta 3GB). Y también, me gustaría decir que ya probé un sistema operativo NAS alternativo (perdón por el posible SPAM, pero creo que ayudará): OpenMediaVault (v5 y v6 beta), y tampoco funcionó.

 

El error se debe a que GRUB no puede acceder / escribir en '/ dev / sdx'. Tanto en unRAID como en OMV falla con el mismo error.

 

Algunos usuarios me dijeron, y también leí algunas publicaciones en Internet, que podría estar relacionado con la cantidad de RAM disponible que tiene actualmente el NAS. Pero algunos otros usuarios dicen: el error puede provenir de que el kernel (GRUB) no pueda apuntar y montar el disco seleccionado correspondiente para la instalación (/ dev / sdx).

 

He adjuntado algunas imágenes útiles relacionadas a esta publicación. Espero que alguien que esté en la misma situación que yo pueda echarme una mano. Actualmente estoy trabajando con QTS pero mmm, me gustaría volver a unRAID en este NAS jeje. Gracias de antemano.

 

 

 

photo_2021-10-02_00-13-46.jpg

 

Hi @SmartPhoneLover,

 

As I indicate to you in the Telegram group https://t.me/UnRAID_ES of the Spanish-speaking UnRAID community, the first thing we should do is have the minimum requirements recommended by UnRAID for the start-up of our S.O. and from here observe how said new installation behaves.

 

It is logical that you refer to the minimums recommended by UnRAID since from that basis we can rule out possible subsequent error messages. Be that as it may, 1Gb of RAM will always be a very fair size for other situations where you want to perform other tasks in UnRAID.

 

Kind regards

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...