SmartPhoneLover

Members
  • Posts

    187
  • Joined

  • Last visited

2 Followers

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

SmartPhoneLover's Achievements

Explorer

Explorer (4/14)

27

Reputation

  1. Hello unRAIDERS! This is my first little tutorial, so hope it could help to all the users facing the same problem. The topic of this tuto is to get rid of the annoying 'AH00558: Could not reliably determine the server's fully qualified domain name' message that is shown in the container's log, when the corresponding file(s) doesn't have this specific line configured in the base docker image. Well, this warning does not prevent Apache from running, for the normal operation of the container, so it could be safely ignored. But, if you don't want it to be shown everytime you restart the container, or the Apache is restarted for some reason, you can follow this guide. - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Let's take one of my Docker templates as an example: Remote Wake/Sleep-On-LAN Server Previous steps... 1. Install the container, as usual, and start it. 2. Install nano tool inside the container, by opening its Terminal Console, and typing apt install nano or apt-get install nano. Let's go... 1. Open the Terminal Console of the container. 2. Usually, you may need to navigate to /etc/apache2/* directory. 3. Inside the previous dir you should see the file apache2.conf. So, open it with nano: nano apache2.conf. 4. The content of the file will be shown now in the Terminal Console, with some action buttons located at the bottom... 5. Scroll down and add the following line: ServerName localhost. You can comment (#...) it with something you want, if there's no default comment line for it. 6. Press CONTROL + X key combination, then accept saving the changes by pressing Y. Now you can exit from the nano editor by pressing ENTER. 7. Restart the container. 8. Done! Notes... - These steps should be followed everytime you update or rebuild the container.
  2. UPDATE v1.1 (2022-05-26) - New: Added 'PASSPHRASE' variable to allow using a password for the WebGUI. - New: Added 'RWSOLS_MAX_PINGS' variable (declared only in the docker image) to configure the max number of ping calls to send to a device to detect its state. - Fix: The configured webserver's port didn't match with the one set in 'WebUI' port field, my fault sorry. (It worked when I created the template, maybe because it was cached from previous testings) - Other: Changed the webserver's port to 9999, to prevent posible conflicts with the default one (8080).
  3. @domrockt If the container works as expected after setting all the fields, the 'AH00558: Could not reliably determine the server's fully qualified domain name' error can be ignored safely. It does not prevent the Apache from running. Anyway, I will try to find a solution for the containers where the corresponding config files are not correctly configured by their devs. I have created a little guide about how to disable this warning. You can check it here.
  4. This docker template was created based on an already available docker image Website: https://www.jeremyblum.com/2013/07/14/rpi-wol-server/ GitHub: https://github.com/ex0nuss/Remote-Wake-Sleep-On-LAN-Docker GitHub (original): https://github.com/sciguy14/Remote-Wake-Sleep-On-LAN-Server DockerHub: https://hub.docker.com/r/ex0nuss/remote-wake-sleep-on-lan-docker My Repository: https://github.com/SmartPhoneLover/unraid-docker-templates DESCRIPTION The Remote Wake/Sleep-On-LAN Server (RWSOLS) is a simple webapp to remotely power up (wake) and power down (sleep) any supported device via WOL/SOL protocol. NOTES • If you want to use the 'SLEEP' function, additional software will be needed on the client: 'Sleep-On-LAN (SOL)'. A button to sleep the device will be shown, instead of wake device, when corresponding variables are set accordingly. Both 'wake' and 'sleep' options will be shown in the web interface according to the current state of the device. • The values of Name, MAC and IP variables (RWSOLS_COMPUTER) must be intered in the following format: "xxx","xxx". • There are other variables that you can use, if needed. Check the GitHub repo to know more. • When changing the webserver's port, be sure to set the same port number in all corresponding fields on this template. • The default password for the wake/sleep function (button) is: 'unRAID', but you can set your own. Leave it blank (do not delete the variable) if you don't want to enter any. VERSION 1.1 (2022-05-26) If you are going to report a bug or request something to be added/modified, please, take into consideration that I will only be able to apply changes for the work I own only. For example, if I create a docker template for an already existing docker image (not created by me), I won't be able to do more for that image than forward your report or request to the owner of the project.
  5. VERSION v1.1 (2022-05-24) - New: As requested here, the 'PORT' variable was added to allow changing the internal port. - Other: App icon updated.
  6. @NotHere You can ask the developer to make some screenshots of it and upload them to GitHub repo.
  7. Well, you can try another approach if what you don't want is to clear it manually. If you're using Firefox... 1. Open developer console (Control + Shift + I). 2. Click on the '3-dot' icon, located on the top-right. Then, click on 'Settings'. 3. Locate the 'Advanced Settings' (scroll down a bit). 4. If not enabled, do it for the 'Disable Cache (when toolbox is open)' option. 5. Restart the browser. Now try loading the container again in a normal window.
  8. @Gerben321 Try cleaning the cache of your browser (firefox, chrome...). Then, launch it again. The same is applicable for any noVNC connection. Note: Another alternative is to open it in private mode, so you won't need to clear the cache.
  9. Yes, it's a known bug. You can keep track of it here. For me is happening exactly the same thing.
  10. UPDATE v1.1 (2022-05-23) - Fix: Added '--name' parameter (Post Arguments) as mandatory to try to avoid connection issues from the server, when performing several requests in a short period of time. You can customize it with your favourite username if wanted. - Other: Other minor changes on the template.
  11. Sorry, but I didn't show this message, or warning. Maybe it was happening time ago, when the service was in early development, and also the dev was experiencing some little problems with the integration and communication woth the server from the dev that provides the books. Now, seems to be working maybe a bit better than before? I only experienced this when I forgot to clear the search field content when reloading the page or restarting the container. Seems that it resumes the search if the user doesn't clear that field before shutting doen the container. Any way, the developer of this image seems that does maintain it anymore (> 3 months without updates and/or GitHub issues replies). So, I will mark this template accordingly. I already tried using the Group/User ID variables, but them are not included/declared in the code. So, the only solution that I can think of, is creating a Cron Job (unRAID) with User Scripts (plugin) to automatically change the permissions of all the downloaded ebooks in the corresponding directory, periodically. Here you can find a good article about it: link Do you know a way to solve that if not getting the results from that source?
  12. I have build it, but I'm getting infinite errors (console): WARN [DataGatheringService] Faild to gather data for symbol USDEUR from YAHOO at xxxx-xx-xx It makes the container to overload the CPU (server). https://github.com/ghostfolio/ghostfolio/issues/924
  13. Hello, thank you very much for this template! I will tested it! Note: You forgot to include the 'REDIS_PORT' variable.
  14. UPDATE v1.1 (2022-05-22) - Fix: The container would not start after building it, because the 'curl' cmd was incomplete. Sorry about that! - Other: Updated the plikd.cfg file with latest changes. - Other: Other minor changes in the template.
  15. @sergio.calheno I couldn't replicate your error, as 'Bad Parameter'. But another error appeared instead: docker: Error response from daemon: failed to create shim: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: rootfs_linux.go:75: mounting "/mnt/user/appdata/plik/plikd.cfg" to rootfs at "/home/plik/server/plikd.cfg" caused: mount through procfd: not a directory: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type. This appeared because I forgot to add the last part of the 'curl' cmd in the NOTES section, because the CFG files that contains the configuration of the container was missing (not downloaded), so the container couldn't be started. I already fixed it. Now the NOTES show the correct (full) sets of cmds that need to be executed before building the container. Also, I have updated the CFG file content, because the original one was modified several times (last changes just 5 days ago). Try rebuilding the container again, and let me know if it works for you now. Don't forget to delete all possibles files and dirs that could exist under '/.../appdata/plik/*' before.