Help requested (What am I missing?)

Recommended Posts

Problem: Win 10 Pro VM using a GPU won't allow RDP or VNC from within LAN


FWIW, I've had lots of successes running similar VMs on VirtualBox on Windows (within Windows, Linux or OSX), but this KVM system, I've got to be missing something... and I'll happily buy a beer (or two) for anyone who has an answer that will allow me to solve this problem.


Server Specs:

 Server: Dell T310, Xeon X3480 (4c/8t, 3Ghz, 30-50% CPU utilization), 32GB DDR2, 6x4TB drives (20TB+Parity), with battery UPS

 LAN: Gigabit ethernet, Google NEST router (stable) connected to VerizonFIOS (300/300) 

 GPU: AMD R7/240 in PCI Express Generation 2 8X (in Full Length Slot 2)

 OS: unraid 6.9.2


Background: Yes, just to say it, I've been through SpaceInvaderOne's VM primer (THANK YOU!)... and re-watched it about 50 times. But there's something I am missing. And it's frustrating the heck out of me. The goal is to have a windows 10 VM using a GPU that I can remote into, away from my local network, but at present, I'm not even able to remote into otherwise stable VMs when using my graphics card within my own LAN.


The Dell T310 Server has running the 6.9.2 unRAID - stably (for weeks, and before that, for months), and I have been running Windows 10 (Pro x64) VMs using the RedHat QXL Dirver and VNC into it without much of an issue. But unfortunately I have been having significant issues with remoting into them whenever I start to use a GPU. The server's main GPU is on the motherboard (Intel) - but the add on GPU is a MSI Brand AMD R7/240 card, in the second PCIe (8x) slot. (The SAS controller is in the primary slot.)


If I build/start the VM running windows 10 Pro x64 using the redhat QXL Driver, everything seems to run well, and can continue running for days (weeks) - and I can locally get into it with VNC, Google CRD or MS/RDP without problem.


However, when I "switch" any stable VM over to using the R7/240, sometimes it will work, and sometimes it will not. Sometimes, I will have to detele the VM as even going back to the QXL driver won't allow me to VNC into it from within the LAN. And often, it will work for a day or so, then it will become "unavailable" to wither CRD or RDP . Sometimes I catch it trying to update the drivers or Windows, and can halt that - but often, something still "happens" and I loose the ability to connect - perhaps a day or two later. Restarting the VM or the server seems to have no real positive effect.


Sometimes, if I change the driver back to QXL, the VM seems to work fine again and I can VNC into it. But afterwards - when I switch primary video over to the GPU - while the VM status board it says it's started, I can't remote (regardless of trying VNC, RDP, or CRD) into it. And yes, I've let it run for "days" just in case it was a windows update, but that doesn't appear to be "the issue" either. I also tried switching it to a separate (unassigned) SSD Drive, and while that helped execution speed, it did nothing for the ability to RDP into it.


I even tried RealVNC server (from ninite) - and just got the same results (unable to remote into it). Also when I try to add QXL as a second (or first) video option in the VM, to do a dual video- I also loose any ability to connect into it remotely via VNC, RDP or CRD. The same results were also happening with a nVidia 610 card. Although I got far more 43 type errors with every try I made.


As far as I can tell, I don't appear to have any IOMMU conflicts, and I've tried various VM settings for machine type (i440fx-3.1 or Q35-51 or lower) and bios (OVMF or SeaBios), with no success. Again, sometimes I can get a VM to start up fine, run for a day or two... then it seems to get lost, and I can't remote or VNC into it again, until I go back to the QXL video option. And then, after I can remote into it again using QXL - switching or adding the GPU - causes it to "get lost" again.


Am happy to provide any additional details (please point to whatever procedural diags you want the data from, as at this point I happy to post them, I am just unfamiliar with what is the right thing to post for getting help to solve this problem.)


So, what am I doing wrong?


Thank you for reading... this has got me pulling my hair out, and I don't have enough of it to spare these days.

Edited by rollieindc
header edit
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.