Jump to content
muthukumarank

Rsync errors using Delta copy

6 posts in this topic Last Reply

Recommended Posts

Newbie here.

 

Thanks for the Great forum and unRaid community , I was able to setup my unRaid server and is working great. Intial setup is small 2X2TB Drive and a 2TB parity drive. I plan to expand later once initial kinks are resolved.. Past few days I have been trying to setup rsync so that i can backup all my PC's( 1 PC and 2 Laptops) important files to unRaid server everyday. All my PC's are either win 64 machines or Vista. Installed Delta copy in all these machines.

 

I read every topic on rsync in this forum(Tibbar-WeeboTech) but still rsync is not working in my setup. I have setup rsyncd.conf file and s20-init.rsyncd file as well as described.

 

Here is the error that I am getting. I am complete noob to linux. so please help me.

 

root@Tower:/mnt/disk1/backup# /usr/bin/rsync rsync://Tower/

 

rsync: connection unexpectedly closed (0 bytes received so far) [receiver]

rsync error: error in rsync protocol data stream (code 12) at io.c(632) [receiver=3.0.4]

 

I tried IP address as well still same error

 

>:(

 

Share this post


Link to post

That error tells us rsync doesn't have enough information to do what you want. You'd get the same thing using "rsync horned:toad".

 

It can be used many ways, but is generally called with more than what you show in your example.

 

e.g.

rsync -optionsandsuchthatoftenlookugly source destination

 

Could you maybe reference a thread you learned from that would provide context?

Share this post


Link to post

Cyrnel

 

Some more additional info. my thought process was to setup rsync in unraid box as a server and deltacopy as client running in various PC's. I will then schedule backup run using deltacopy. But right now I am trying to test rsync @ unRaid and make sure it is setup correctly at the server end.

 

1. my rsyncd.conf is setup in /boot/custom/etc and /etc as described in the forum topic

 

uid            = root

gid            = root

use chroot      = no

max connections = 4

pid file        = /var/run/rsyncd.pid

timeout        = 600

log file        = /var/log/rsyncd.log

 

[backup]

 

path      = /mnt/disk1/backup 

comment  = /mnt muthu files   

read only = FALSE

list      = yes

 

2. my S20-init.rsyncd file stored in /boot/custom/etc/rc.d/

 

#!/bin/bash

 

if ! grep ^rsync /etc/inetd.conf > /dev/null ; then

cat <<-EOF >> /etc/inetd.conf

rsync  stream  tcp    nowait  root    /usr/sbin/tcpd  /usr/bin/rsync --daemon

EOF

read PID < /var/run/inetd.pid

kill -1 ${PID}

fi

 

cp /boot/custom/etc/rsyncd.conf /etc/rsyncd.conf

 

3. Go Script I added a line

/boot/custom/etc/rc.d/s20-init.rsyncd

 

Now I tried to check running rsync @ unRaid I am getting the above error. your direction is appreciated.

Share this post


Link to post

Here syslog Error msg

 

Apr 28 17:19:43 Tower rsyncd[2924]: bind() failed: Address already in use (address-family 2)

Apr 28 17:19:43 Tower rsyncd[2924]: socket(10,1,6) failed: Address family not supported by protocol

Apr 28 17:19:43 Tower rsyncd[2924]: unable to bind any inbound sockets on port 873

Apr 28 17:19:43 Tower rsyncd[2924]: rsync error: error in socket IO (code 10) at socket.c(541) [receiver=3.0.4]

Share this post


Link to post

A quick look says init doesn't know about rsync yet. If you haven't rebooted then you need to run your S20-init.rsyncd yourself. Next time you reboot the go script will have done it for you.

 

Edit: Note your example here mixes "s20-init.rsyncd" and "S20-init.rsyncd" somewhat. Remember n*x is case sensitive so be careful of that.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.