Lost Web-Interface after Updating 6.10.1 to 6.10.2


Go to solution Solved by Vr2Io,

Recommended Posts

  • Solution
Posted (edited)

Use Broadcom NIC with tg3 driver and enable VT-d ?

 

If yes, you can edit the config file ( "Syslinux Configuration" ) to add intel_iommu=off or unplug the USB to another PC to edit it.

Or

Create a blank tg3.conf file to un-blacklist the driver if you confirm no corrupt issue by tg3+VT-d.

 

Data Corruption possible with tg3 driver when Intel VT-d is enabled.

The combination of Linux 5.15 kernel, tg3 driver, and Intel VT-d enabled appears to be causing data corruption.  This has been verified on several platforms which include a Broadcom NetXtreme Gigabit Ethernet NIC (note: there may be others).  This release includes the following workaround:

 

Very early in server startup (rc.S) if Intel VT-d is detected enabled, then the script will unconditionally create the file:

/etc/modprobe.d/tg3.conf

with following content:

blacklist tg3

Hence by default if VT-d is enabled, which is to say, it has not been disabled in either bios or via kernel "intel_iommu=off", then we are going to blacklist the tg3 driver on all platforms.

What if someone has a platform where tg3 does not give them any trouble with VT-d enabled? In this case they must create an empty file on their flash device:

config/modprobe.d/tg3.conf

When the startup sequence continues it will get to the point where it executes:

install -p -m 0644 /boot/config/modprobe.d/* /etc/modprobe.d

A blank tg3.conf file stored on the flash then effectively un-blacklists it.

There will be users who will lose network connectivity because their NIC is blacklisted. If you are running on a problematic platform you should go into your bios and disable VT-d. If this is a platform without issue, then you will need to create the blank tg3.conf file on your flash config/modprobe.d directory.

It may take some time to identify and integrate a proper fix for this issue, at which point we will remove the auto-blacklisting code.  I want to thank @JorgeB for his incredible help in identifying and isolating this issue.

 

 

 

 

 

Edited by Vr2Io
  • Thanks 1
Link to comment

Btrfs already found some corruption and there are the typical call traces logged, you should disable vt-d now, if you really need it you should go back to v6.9.2 for now, note that you can still run VMs with vt-d disabled, just not able to pass-through any devices to one.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.