Jump to content

Can't get Windows 10 VM with GPU Passthrough To Boot

Go to solution Solved by FiNakoma,

Recommended Posts

Been having loads of issues getting a Win 10 VM with GPU passthrough for my Asus AMD 6600XT. I had it working on an old VM with virtually identical settings to this one. The only difference is that I'm accessing an NVME directly instead of using a VDISK image. I've since broken that VM completely so can't access it anymore. 


I can get into Windows if I use the standard VNC driver but I keep running in to the following error:




2022-11-16T14:40:48.353261Z qemu-system-x86_64: terminating on signal 15 from pid 11343 (/usr/sbin/libvirtd)



Full logs https://pastebin.com/8CcbDFjX

Attached my diagnostics 


I've tried loads of guides tried about everything I can find on google/unraid forum/reddit. :( Stepping away before I lost my mind.. 


Here's my VM config: 




Link to comment
  • Solution

For anyone who has this issue I spent ages and loads of things to fix it and eventually found this post: 




Removing the following from the VM XML file and boom VM boots absolutely fine and I can see my GPU in device manager: 


      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
      <vendor_id state='on' value='none'/>


  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...