Really need help getting an old 8TB 5.0.4 server back online.


Go to solution Solved by trurl,

Recommended Posts

Ok, so back in '13 life really screwed me over for a bit.  My machine with my Unraid key backup literally caught fire, we had 2 young kids and some major heath stuff going on.  Not a problem, the server was fine.  Forward a few months and the server was not fine, it died and I did not have time or energy to revive it. 

 

Now, I have the hardware alive only to find out what had died was the USB key.  I think I have the GUID of the old drive and I have my Plus license key and I had an old copy of the Unraid image.  Today I restored the image, but need to get my Plus key to work.  I think that I need to have someone do some magic with the GUID of my new drive to get it working? 

 

I think I can identify the parity drive because it should be one of the two largest drives in the server, and of the 2 I think I built it will the parity drive on the last sata port in the system.  I also believe that the drives sda to sde are in the order the system was built.  Just have to get this key issue sorted.  Tom Mortensen with Lime had helped me get it going back then and I worked with him on some beta ethernet drivers in this version to support my mobo.  Not even sure if he is still with them.  I will also need an image of 5.0.4, I think.

 

Any help would be appreciated greatly.  If I get it running, I will want to upgrade to something current, if I can.

 

Thanks Matt

 

PS can I bring the server up with the parity drive and the first 2 drives only without screwing up the other drives?

Edited by mattw
Found my last post here with version information and a drive map!!!
Link to comment
  • mattw changed the title to Really need help getting an old 8TB 5.0.4 server back online.

Posting this as a follow up... I have not tired to bring the array online, but I did make a brand new USB key and placed my key file on it and the system is booting 6.11.5 and I was able to register the new key with my Plus license!

 

My CPU is an AMD A4-5300 with 8 gigs of ram...

 

These are the installed drives and I believe the first 2 that cannot be read are the parity drives.  How should I proceed?

image.png.1e9324dfdd64da0c14a89fd96d0110f9.png

Edited by mattw
Further updates
Link to comment

image.png.d9794f63f1075e3038c47afaa8a215eb.png

 

Be careful as you attempt to assign drives to either data or parity.  If you follow the procedure that @trurl provided a link to, you should have only one drive that is unmountable.  All Unraid version 5 distributions had only single parity.  Dual parity was introduced first in Version 6.2

 

The reason for the caution is that you have two flagged with SMART errors.  That does not mean that the disk can not be mounted but only that it has issues that should be evaluated in the near future.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.