Jump to content

Disable VNC Console with GPU Passthrough - System won't boot.

Recommended Posts

So I have a weird issue where if I have my GPU passed through it works just fine as long as I have the virtual display enabled in the xml. However the moment I disable the VNC console the VM will no longer boot up. Any suggestions? Nothing stands out in any of the logs. Normally I wouldn't care but I have a script for a game I run and for whatever reason it see's the other displays resolution instead of the actual display being used.  I did try disabling it in windows device manager but it still looks at it's resolution. So I am stuck with trying to figure out how to disable it completely.

Edited by josh5565
Link to comment
  • josh5565 changed the title to Disable VNC Console with GPU Passthrough - System won't boot.
  • 3 months later...

I had the exact same issue. My Mac booted fine with VNC + passthrough Nvidia GPU, and the Mac can find the GPU correctly and utilize it for second monitor. But after removing VNC it wouldn't boot. Turns out the ROM I used for the GPU was not working for VM (I used one that's directly downloaded from techpowerup vgabios database without modification).


I had to follow this to modify the downloaded vbios to make it work for VM.



Dumping vbios might also work but I didn't had luck with it


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...