SMB share, all "old" files are invisible to Windows

Recommended Posts

I'm going to try to condense this down as much as possible without leaving out anything important...


I have a media share at 


It is set as follows:

Use cache pool: yes
cache pool: cache
CoW: auto
Export: yes
Security: Private
User access: R/W

I recently moved all my data from an old UNRAID server using an SMB share on the old server as a mount point, and pulling the data with:

rsync -avh "/mnt/remotes/$OLDSERVER/media/" "/mnt/user/media" --progress --stats --iconv=.

I then did some other stuff, setting up and configuring my media managers etc... all mostly behaved as expected, although *rr did seem to struggle with some files that did not have valid filenames... I remediated those manually by using mv $BADNAME $GOODNAME in the console


Now the trouble begins...


when I browse to the media share from UNRAID, from either the share browser, the root console, or a docker console with a mount point there, I can see 800+ files in /mnt/user/media/video/movies. 


expected behavior: see the same when mounting the SMB share from windows


observed behavior: only see the ~ 100 files that were created on the share *after* the data migration. 


Troubleshooting steps already taken:

  • set windows to display hidden and system files -- no change
  • run docker safe new perms -- no change
  • disable docker, disable VMs, reboot the server, disable SMB, start the array, mount the array, run New Permissions on all shares except for appdata, dismount the array, stop the array, enable SMB, start the array, mount the array, remove and recreate drive mapping in Windows. -- no change
  • tried on another computer -- no change

Link to comment

Type this command in a GUI terminal  (the    >_       icon on the GUI menu-bar near the top-right side):


ls -al /mnt/user/media/video/movies


Get a screenshot of the output for some files that windows can not see.


Then type this command:

ls -al /mnt/user/media/video


This time get a screen shot of the entire output.


Post both up in a new post in this thread.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.