Disks reporting Read Errors when parity and data disk are in array

Go to solution Solved by JorgeB,

Recommended Posts

Hey, I've got a strange issue. Whenever I add a data disk back to the array both my parity and data disk start reporting read errors.


- I've tried changing the SATA and power cables (use different power cables from the PSU).

- I've also added a 3rd disk and rebuilt the array on that and that worked so I do have a backup in case both my current drives are faulty.

- I've ran the extended SMART test on both drives and they had no issues reported

- Running read test on only parity drive right now and no errors reported thus far (when both disks added the errors start showing immediately)

- I've also moved the data drive to a external disk bay and formated it and checked SMART there the extended test and it also had no errors


The issue only occurs when both drives are added to the array.


My last option I can think of is to blow the array and recreate it and see if that helps.


I'm on unraid 6.11.5 and have 2 Seagate Ironwolf 1TB drives as the array. And I have 2 500GB Samsung SSDs for cache in raid1. All of them are using BTRFS as the filesystem.


Link to comment

I don't think it's the controller since the cache drives are on the same one and are not affected. The other SATA ports I have on the board have a different controller and I have that one passed to a VM. And I did have something simmilar happen to those disk also once and reconnecting the cables fixed it in that case so I was under the impression the issue was with the cables.


Thanks for the idea, I'll try the controller I'm passing through with these disks to see if the issue persists.


If this is the issue I guess I'll see if my MB is still under warranty but I don't know how to prove to the shop or the importer that it's faulty ...

Link to comment

I've moved the disks to the second SATA controller and it appears there are no read errors here. The array is rebuilding now. Once it's done I'll try to pass the "broken" SATA controller to the VM and see if it has the same issues there with the other disks. If this will work I guess it's possible that the "broken" controller has issues with 4 drives attached but not 3 as there were no read errors with 3 drives attached to it.


I guess I can check the BIOS to see if I can change anything to fix that else I'll try to get some info about the warranty on the MB, but I think it's no longer covered since I bought it quite a long time ago.

Link to comment
30 minutes ago, khartahk said:

I don't think it's the controller since the cache drives are on the same one and are not affected.

Yes they are, they are also dropping, you just don't see it in the GUI.:


Jan 26 10:18:39 Tower kernel: BTRFS error (device sdb1): bdev /dev/sdb1 errs: wr 0, rd 1, flush 0, corrupt 0, gen 0
Jan 26 10:18:39 Tower kernel: BTRFS error (device sdb1): bdev /dev/sdc1 errs: wr 0, rd 1, flush 0, corrupt 0, gen 0



Link to comment

I see. Thank you for this.

Is it possible the controller has issue with 4 drives but not 3? Since the read test worked without any issues when I had 2 SSDs and one HDD connected to it and how could I go about testing this other then for example connecting just 2 drives to see if they work?

Link to comment

There have been issues with onboard Ryzen SATA controllers in the past, where they dropped out under intensive use, like parity check, disk rebuild, etc, it's much less frequent with latest Unriad and newer kernel, but t still happens, also look for a BIOS update, sometimes can help.

  • Thanks 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.