RSYNC woes?


Recommended Posts

I am backing up one of my folders on my unRAID server to a directly attached drive via the Unassigned Disks plugin. The folder contains a bunch of family documents (PDFs, pictures, family videos, etc.) about 1.2TB in total. 


In the past I have used RSYNC and it has worked well. This is what I ran this time:

rsync -avh --info=progress2 --partial --log-file=rsynclog.log /mnt/user/Documents/ /mnt/disks/external/documents_backup_2023-02-12/


RSYNC was copying just as I expected until it reached a subfolder where I backup my cellphone pictures every few weeks. It hung on a single picture (roughly 5MB). I manually moved that picture and re-ran RSYNC and it hung again on the next picture. At this point I wanted to finish backing up everything else and ran this:

rsync -avh --info=progress2 --partial --exclude '/Phone Pictures' /mnt/user/Documents/ /mnt/disks/external/documents_backup_2023-02-12/


That command ran just fine and finished everything else. 


I then went back and tried to just RSYNC the 'Phone Pictures' directory and it kept hanging. I used logging and verbose mode and didn't get anything useful, just stopped mid transfer for over an hour. If I re-ran it again it would stop on the exact same file too. Until I manually moved it and it would hang on the next file. 


I eventually gave up and ran this:

cp -R /mnt/user/Documents/Phone\ Pictures /mnt/disks/external/documents_backup_2023-02-12/

That ran just fine and I verified the files were all transferred. 



I have never had issues like this with RSYNC in the past and I am not experienced enough with it to know how to properly troubleshoot. Is there anything I can do to provide more logging? Or any ideas what the cause might be? I was hoping to try and automate this backup to run once every few months.



Link to comment
19 minutes ago, trurl said:

Did you check that log?



Doesn't show anything more than the verbose output. Actually less.

It was only a list of files transferred. It just stopped at the file before the one RSYNC hung on. 


2023/02/12 22:28:04 [13522] >f..tpog... Phone Pictures/IMG_20200220_055619.jpg
2023/02/12 22:28:04 [13522] >f..tpog... Phone Pictures/IMG_20200221_073231.jpg
2023/02/12 22:28:04 [13522] >f..tpog... Phone Pictures/IMG_20200221_122321.jpg
2023/02/12 22:28:04 [13522] >f..tpog... Phone Pictures/IMG_20200221_124635.jpg
2023/02/12 22:28:04 [13522] >f..tpog... Phone Pictures/IMG_20200222_120952.jpg
2023/02/13 07:38:57 [13522] rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(642) [sender=3.1.3]


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.