Jump to content

Slow write performance on EARS drives


Recommended Posts

I am new to unRaid, so please bear with me.  I recently built a new unRaid server with 3 EARS (2TB) drives, 1 EADS (2TB) drive and 1 Hitachi (1TB) drive.  My motherboard is a SUPERMICRO MBD-C2SEA-O.  One of the EARS is the parity and all other disks are data.

 

The trouble that I am having is that the write speeds to these EARS drives is < 4.0 MB/sec.  I have tried copying files directly to the Hitachi and the EADS drive and I get anywhere from 35 - 45 MB/sec, so I think my network, mobo, etc can be ruled out.  While the file is copying, the data drive has a solid activity light and the parity will blink occasionally.

 

Here are some things I have tried (all to no avail):

 

1.  I removed one of the EARS drives, restarted the array and attempted to let it rebuild the disk from parity.

 - The write speed for the rebuild was < 4.0 MB/sec and I canceled it and gave up

 

2.  I then read the posts all over the forum about the jumpers and then attempted on this same disk to set the jumper and rebuild the disk from parity.

 - This resulted in a much better rebuild speed of ~20.0 MB/sec.  But, once the disk was completely rebuilt, the write speed was the same as before.  (I don't understand why rebuild would be able to write data to the disk faster than a normal write, but this is what happened)

 

3.  I was running the beta 9 release and thought maybe I would try to just start over from scratch with no jumpers and just make sure that I had everything setup on 4.7 with these disks the way this post suggests.  But, with the jumper removed from the disk mentioned in parts 1 and 2, the disk would simply hang with the activity light solid for 30 - 45 seconds before the OS would start completely.  So, I figured that this disk must be bad.  So, I removed it and replaced it with another 1TB Hitachi, and moved my EADS drive to be the parity.  All started up perfectly, the data from my remaining disks was still there (cool) and the parity built at ~50MB/sec on the EADS disk.  So, I thought that all was solved.  However, now I go to write data to the two remaining EARS disks and I again get < 4.0 MB/sec write speeds.  I attempt to write data to either of the Hitachi drives and I get > 40MB/sec.

 

I have no idea what I am doing wrong here.  These drives seem to show performance that is reasonable for the parity sync and rebuild operations (~20MB/sec), but any other sort of write to these disks is incredibly slow.  I have run this command: fdisk -lu /dev/sda on all drives with the following results similar for all disks:

root@Tower:~# fdisk -lu /dev/sda

 

Disk /dev/sda: 2000.3 GB, 2000398934016 bytes

1 heads, 63 sectors/track, 62016336 cylinders, total 3907029168 sectors

Units = sectors of 1 * 512 = 512 bytes

Disk identifier: 0x00000000

 

  Device Boot      Start         End      Blocks   Id  System

/dev/sda1              64  3907029167  1953514552   83  Linux

Partition 1 does not end on cylinder boundary.

 

 

If I am reading this right, it appears that I am aligned on 64 with no jumper.  Which if I have read this post correctly, I have this setup right.  Other than get on Newegg and pony up another $300 for disks that actually work, I don't know what else I can do.  Any help or suggestions would be appreciated.

 

** Additional info **

The EARS drive I removed from my unRaid machine works perfectly in my Windows computer.

 

-- Chris

syslog.txt

Link to comment
  • 2 years later...

I know this is an ancient thread, but did you ever figure this out? Disk7 (and my parity drive!) are both WD20EARS drives...

 

Writes are slow, but reads are fast.

 

Write test: for n in 1 2 3 4 5 6 7;do dd if=/dev/zero of=/mnt/disk$n/test.dd count=8192000 bs=64k count=8k conv=fdatasync;done

 

- disk 1: 31.4 MB/s, 30.4 MB/s, 39.6 MB/s

- disk 2: 31.7 MB/s, 32.5 MB/s, 35.3 MB/s

- disk 3: 29.5 MB/s, 28.4 MB/s, 31.0 MB/s

- disk 4: 22.6 MB/s, 24.9 MB/s, 24.8 MB/s

- disk 5: 20.0 MB/s, 15.2 MB/s, 21.0 MB/s

- disk 6: 36.3 MB/s, 32.8 MB/s, 30.9 MB/s

- disk 7:  4.7 MB/s, 13.6 MB/s, 14.9 MB/s

 

Read test: for n in e g l f k j i;do hdparm -tT /dev/sd$n ;done

 

- disk 1: 132.49 MB/s, 132.42 MB/s, 132.65 MB/s

- disk 2: 189.77 MB/s, 189.02 MB/s, 189.73 MB/s

- disk 3: 103.08 MB/s, 106.94 MB/s,  71.25 MB/s

- disk 4:  83.80 MB/s,  83.57 MB/s,  83.87 MB/s

- disk 5: 183.32 MB/s, 184.27 MB/s, 185.22 MB/s

- disk 6: 118.64 MB/s, 117.98 MB/s, 118.46 MB/s

- disk 7: 112.98 MB/s, 110.85 MB/s, 110.65 MB/s

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...