Jump to content

Can't add new disk to xfs-encrypted array


Go to solution Solved by JorgeB,

Recommended Posts

I can't add a disk with xfs-encrypted format to my array. I've pre-cleared the disk, added it to the stopped array and set the format for that disk to xfs-encrypted (as for all the other disks in the array). When I start the array, a rebuild is triggered and I also get the "format" button. When I press that, it shortly says "formatting" but right after that it says "Unmountable: volume not encrypted". It also stays that way when the rebuild was done after 7h. I then tried again to format the disk, but the same happend, shorty showing "formatting", follow by "unmountable". I've also set the default disk format to xfs-encrypted as I've read something along these line in the German section of the forum, but to no avail. Does anyone have an idea how I can add an xfs-encrypted disk to my array?

tom-diagnostics-20230529-1830.zip

Link to comment
May 29 22:22:02 Tom  emhttpd: shcmd (45081): mkdir -p /mnt/disk6
May 29 22:22:02 Tom  emhttpd: /mnt/disk6 mount error: Volume not encrypted
May 29 22:22:02 Tom  emhttpd: shcmd (45082): umount /mnt/disk6

 

Do you have a script or are you manually deleting the encryption key after array start?

Link to comment

I have the array set to auto-start and have a script that fetches the array passphrase from another machine. My guess is that this somehow trips up what I wanted to do. I've now got working what I wanted but not the way I wanted it (and I guess it isn't supposed to be that way). What I did now:

  1. stopped the array
  2. removed the disk that is unmouintable and can't be formatted
  3. rebooted the machine
  4. as a disk is missing in the array, it wouldn't auto-start and I get the option to enter the passphrase for the array
  5. added another disk to the array
  6. started the array which cause a rebuild due to the new disk
  7. now when I press "format" for the new disk, it does indeed format it and it is also encrypted.
  8. the capacity of the new disk is already emulated so I'm confident in 7 hours time when the rebuild is done I have an array of encrypted disks.

I'm not really sure why I was bitten so badly, I assume it is related to the auto-start of the array, but that's just a gut feeling. The next time I'll add a new disk, I'll disable auto-start and see if typing in the passphrase of the array again saves me from going through this again.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...