Jump to content

[SOLVED] Red Hard Drive, Still Can Access


Recommended Posts

Hi everyone, just logged in and noticed Disk 2 is red (Hitachi), before it didn't show the temp when it was red and failed a Smart test. So i pushed it in the bay more firmly and it passes the test and shows temp but still red, with orange start. I can still access the disk and shows all data. What should i do?

 

Using 5.0-beta8d

IBM Br10i

3x 10EADS

3x Hitachi 2TB

 

Would you like me to upload the syslog file? It looks fairly long..

 

Thanks guys. ;D

 

EDIT: The problem seems to be solved, must of been a loose cable or something.

Link to comment

What I had to do was: (yesterday funnily enough)

 

Stop the array, un-assign the disk with the red ball on it, start the array, stop the array and then assign the disk which had the red ball back to the slot and then start the array again.

 

It will then build all the data back on to that drive which will take some time!

 

Somebody who has done this more than myself no doubt will confirm the above actions.

 

But basically from what I've read once you have a red ball on a drive unraid wont automatically "Fix it" it needs some user action.

 

Hope this helps. 

 

 

 

Link to comment

I just tried it and it still red, it was blue but not for long. Plus sometimes i hear a clicking sound but not always. Dead drive? if even it passed smart or that doesnt mean anything.

EDIT: The sound doesnt last for long even when the hdds are spun up, now it says Partition format: error

Link to comment

Hey guys sorry for the late reply been busy, i just did that command above where you remove the disk from array, start it then shut it down then re add and its rebuilding it now. Before when i tried this it would not work, but now it seems to be rebuilding. We shall see how it goes.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...