Jump to content

New GPU, Can't seem to get passthrough to work

Recommended Posts



So I recently got a new GPU and was able to slot it in to my 6.11 build pretty seamlessly. It worked great in my existing VM and all was good. Well then 6.12 released and I messed something up when transferring the vdisk off my cache to convert it to ZFS. Well thats annoying but all my data is still there otherwise so just needed a new OS set up. However now I can't for the life of me figure out how to get the passthrough working again.


  • All my BIOS settings are fine CSM and IOMMU are enabled
  • Adding multifunction='on' and changing the sound card to match the bus of the video card
  • Tried also adding this other bit to the xml for GPUs with high memory amounts:
  • Tried OVM/SeaBIOS
  • Tried UEFI/Legacy
  • Tried no vBios, dumped vBios and one from techpowerup with the header removed (wasnt 100% sure I have the TUF 4090 and Techpowerup only had one for the strix but I assumed they were close enough).
  • Have a HDMI and DP monitor attatched to GPU
  • Syslinux:
    • kernel /bzimage
      append initrd=/bzroot vfio_iommu_type1.allow_unsafe_interrupts=1 pcie_acs_override=downstream,multifunction video=efifb:off


Everything seems to launch fine, and I can access the VM from RDP, but the GPU is not recognized by the VM and nothing shows up on any of the monitors.


Thanks for any help you can provide.

e: As I was writing this I think the SeaBIOS version actually worked but now it wont boot at all.. I'll play around with it more and report back. I unfortunately didnt attatch any USB devices because I just wanted to make sure it works.


Link to comment
On 6/26/2023 at 3:31 PM, ccowin said:

I got it running on the old 2080ti but I cant get it working on the new 4090. Always a black screen.

Was that using seabios or OVMF.

I have an issue passing through GT1030 seabios to v6.11.5.

OVMF seems to work.

Everything works on 6.9.2

I was hoping 6.12 might fix it but haven't tried yet.

Link to comment
  • 3 weeks later...

I am running 6.12.1 for some days and had trouble getting my Palit GTX 1060 3GB to passthrough.


Eventually today I tried the it WITHOUT a vBIOS. Not modified, not unmodified. It just works!

With vBIOS (modified or not) it wouldn't start the VM. It would hang with 100% on one Hyperthread.

I think they added nvidia support? For some cards at least?

I don't know. But i am Happy that it works! I was just one or two steps away from going back to 9.6.2

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...