Jump to content

Transcode / direct play Plex im sick of it, ill pay for help

Go to solution Solved by NewDisplayName,

Recommended Posts

Im used that some files wont play, but since ive moved ALL my files to h265 to save some space its getting out of hand, it feels like most of the media is not playable.


1.) direct play shows black screen, sometimes direct play works flawless

2.) transcode does work on some files, but not all


What is the problem, i dont get it, other users report that h265 playback is working fine. I dont think i changed anything special in plex, chrome, unraid, just plain "standard", i worked thru all docker pages and i dont see a problem. ITS CRAZY.


Currently i would be satisfied if atleast all media would work in chrome (web). That should be archivable?!!?


In the longrun i have a chromecast ultra for my TV


What i did to fix?

- different nvidia drivers

- different unraid versions (currently latest version)

- different plex/docker versions (currently back to linuxserver)

- i completly removed the nearly 10 year old plex DB and rebuild it

- completly removed chrome (and lost my lastpass pw... xD)

- in sum maybe half a year of googling?!



- Unraid 6.12.1

- Plex

- Nvidia NVIDIA GeForce GTX 1050 Ti  v470.182.03 (also tried latest v535.54.03)

- docker cmd -e VERSION= -e NVIDIA_VISIBLE_DEVICES=all --runtime=nvidia -e PUID=99 -e PGID=100 --device=/dev/dri:/dev/dri --restart=unless-stopped --log-opt max-size=50m --log-opt max-file=1 --network=filesharing -e ADVERTISE_IP=",http://externaldns:32400"

- i tried with and without "nvidia patch"... 



Thats the f.... worst part. Its a nightmare, because plex is unable to f. say what the f. problem is. I get 19q233781298379812978312789387912897312893819072387901218927189203 mrd lines of code spit in my face and can look myself for the error in it. Mostly its super usefull crap like "not supported h4", or absolutly nice errors like:



And to make it even worse the gpu is working fine 24/7 for shinobi.... (...????...)


I would really appreaciate if someone could post their config, so i can test, or if someone would connect to my machine and we see together if we can find out what the f. problem is.


Ill pay if needed.


Maybe my unmanic settings are wrong (??). Ive had it set to main8 and fast or medium before i changed to this.image.thumb.png.d9896ff335ca23f0db665a18a169dabc.png

Edited by nuhll
Link to comment

1) Pick a file try to play it. See if it will. If it doesn't remember the file.

2) Go to the codecs folder in plex (easy audio encoder)

3) Restart plex and see if file plays. 




I've been looking but the stupid mods have locked the r/plex page so I can't access there's a fix where you increase a value that has something to do with how many operations it can do. 


Link to comment

Ive noticed something today.


I think the black screen in orignal quality is a new thing (might be newest chrome or plex) - so that might be temporary.


Then i found out transcode is almost ALWAYS working. Just only in lower quality. Like i can play a video in 2mbits, but not in 20mbits.


THen i thought okay, maybe my GPU is not capable, but i can play lets say 3 2mbits but not one 6mbit? Oo (it doesnt seem to be 100% utilized tho)

10 hours ago, JorgeB said:


Thanks ill look at the rates.


Is it possible to contact them before and clarify if they can help before i pay? Whats when they cant help?


Edited by nuhll
Link to comment
  • Solution

I wrote one of the guys, didnt got a feedback, so i tried something new.


I changed the unmanic workflow to the following:



What i changed was AAC instead of AC3 and i remux (change format to .mp4) and then encode to 265. Im currently converting 70tb of stuff to this format.


All movies i tested so far work now in ORIGINAL QUALITY and even in TRANSCODE via NVIDIA. Before it was JUST encode to 265 and output mkv.



Edited by nuhll
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...