Jump to content

Received "Your flash drive is corrupted or offline"

Go to solution Solved by JorgeB,

Recommended Posts

5 hours ago, JorgeB said:

Did you see that during array start only or it's still showing?

It is still showing sporadically. I don't think it is related to the array starting because it could happen at any time. In fact, I do not think it is related to the USB flash drive at all because I have now a second flash drive it is reporting is corrupted. I have been shutting down, taking the flash drive to my Windows computer and repairing it. It still happens after.

Link to comment

I don't think it is false because the Windows computer does detect an issue with the USB and repairs it. The UI is very sluggish and finally stops responding.


My CPU is very active too, yet no docker or VMs running. Also, this pop up console windows just closes on it's own. This is very strange




Link to comment

I did have a total of 3 webgui's open at the same time. I rebooted. and there is barely any CPU now. Thanks for that.

However, after letting it sit just on the 1 webgui for about an hour, it became unresponsive again. This time it did not require a hard reboot. I was able to change the URL to base URL and refresh the webgui.


I honestly think there is some hardware that is not compatible with 6.12. I should mention this is my second time upgrading to 6.12 from 6.11.5. First I upgraded to 6.12.0 and I was having these unresponsive bouts as well but no flash corruption then. I then downgraded thinking 6.12 was just not ready yet. It seems I have even more problems now.


On top of this, I upgraded to 6.12.2 yesterday to solve another problem. My btrfs cache pool had uncorrectable errors. I could not get it to reformat for the life of me. Erase would not erase. Still showed over 400 GB but I was able to successfully move everything off of it or so I think. Upgraded to 6.12.2 and converted the cache to ZFS and copied system and appdata shares back to cache.


All drives pass abbreviated smart test

Memory check done overnight last night. Passed

No dockers running

No VMs running


Attaching most recent diagnostics



Link to comment
3 hours ago, JorgeB said:

I'm not seeing any flash drive issues in the log, so possibly a false positive, or there's a corrupt config file, don't remember which files are checked, @Squid?

Files that are required and checked:


docker.cfg, domain.cfg, ident.cfg


Files checked if only they exist:


disk.cfg, flash.cfg and share.cfg


And I don't see any issue with those files initially....

  • Like 1
Link to comment
4 hours ago, JorgeB said:

Thank you! This solved it for me. 


I have 1 other issue. My USB ethernet adapter (2nd on the server) does not appear in the network configuration. Yet, it does appear in the system devices. I know I have seen it appear before and was using it as the docker network interface but it no longer appears. I tried renaming the network.cfg to reset the settings and that has not worked. Thanks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...