Jump to content

How to change system files back to normal in terminal


Recommended Posts

Hi All,


Not sure when this happened but some of my media files are recognised by windows as system files and hidden. Is there a command I can change the attributes like the dos attrib command?


I'd like to it to apply to all .iso files for instance (some are system files some aren't)


Like to dos command: attrib -s -h *.iso


Thanks Josh

Link to comment

This is the script I used a while ago and haven't had a problem since


[ -d "$SCRIPT_DIR" ] || mkdir -p $SCRIPT_DIR


cat >$SCRIPT <<EOF

sed -i -e 's/hidden\(.*\)[Yy]es\(.*\)/hidden\1no\2/' /etc/rc.d/rc.samba; /etc/rc.d/rc.samba restart


chmod +x $SCRIPT

echo "$SCRIPT" >>/boot/config/go



Also see this, but haven't used it:



Link to comment

Would that be an issue with the samba shares even though only some show up as system files but others don't?


It seems awfully complex, I thought it was just a file setting. When I copy the file from unRAID over to a windows PC, I can run the DOS attrib command and the file is all good again.


Thanks Josh

Link to comment

It has to do with Samba using unix permissions to translate Windows attributes.

Since I used the script....no more hidden files; and no other issues with Samba.

prostuff1 BRiT also explained this very well...but right now all I could find was this




darn, I almost got credit for something I did not do.  :P

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...