Jump to content

Cache drive made Shares Dissaprear


gisxer

Recommended Posts

ok, i hope i haven't completely screwed my unRAID up.  i've been running a new build for a week or so. i followed all the walk throughs and moved all my data one disk at a time then stared the parity got all green lights, ran a parity check, a-ok and then proceeded to move the disks into the array and format them.  i set up shares and connected laptops, PC, mac and apple tv.  everything was running smooth.  i move a lot of data so i figured i'd add an old 80GB drive as my cache.

 

so i was setting up my cache drive turning on the function for each share. i had several, 'movies', 'music','programs' and the like. then i started testing it but as i moved files to the shares with the cache drive enabled it went right to the array.  meaning i could see the free space drop on a data disk and nothing on the cache drive. after doing some searching on the forum i stopped the array and tried some trouble shooting. i tried changing other settings like 'min size' and then disabling and enabling the cache drive. and starting and stopping the array.

 

then BOOM.  all my shares disappeared.  so i went back to the forums to see why the shares might disappear. i tried  to copy the flash drive and edit and recopy the config\shares files and restarted the array. i tried creating a new share.  it worked when i used the main \\tower page to create the share, but if i created a folder on the root of one of the disks.  nothing.  all my data seemed to be there so whew, because i don't have additional backups since i moved everything the unRAID. then BOOM.  the last time i tried to stop the array it got stuck.  now all i see is the attached status.  it's been that way for an hour.  i don't know what to do.  i don't want to loose anything. i have 750GB of music and a TB or so in movies. i afraid to do anything.  any suggestions would be much appreciated

Tower_-_Main_1316662582048.png.f384480bbfa050525858d9b6f6faedd7.png

Link to comment

help please.  i know everyone is busy.  i can't loose my data.  i don't know what to do.  i have to go to work today.  should i just leave it like this?  should i hard boot the machine?  it's in my basement and not connected to a monitor or keyboard.  so all i have is the web portal. :(

Link to comment

ok, after two long shifts at work i can finally focus on my unRaid.  i took a monitor downstairs and plugged it in.  nothing blank screen. keyboard did nothing.  still couldn't see it on the network any where, nothing.  so i got down on my knees, said a little prayer and hit the reset button.  it came back up and seemed to be ok. it seemed to start a parity check.  i've attached the syslog and a screen shot of the web management.

 

so at least it seems that my data is still there i can see the folders and files on the disk shares on the network. but the user shares are still missing.  i'm afraid if i recreate them it will overwrite the original and i'll loose data. 

how can i get my shares back?

syslog-2011-09-23.txt

Link to comment

I had similar issue tried everything but shares still missing... I installed new the OS, resigned the drives at the same slot and voila, all came back... you want loose data if you don't press delete, format accidentally... :-)

 

Sent from my LG-P990 using Tapatalk

 

Ps. When I was taken out the cache drive shares where there again... resign cache shares gone. That was my case.

Link to comment

YIPPEE!!  all i did was unassign the cache drive and bingo,  everything came back.  i didn't even take it out.  just stopped the array clicked 'unassigned' for the cache drive slot. 

ok, so that is some kind of bug or something?  is there a way to add a cache drive after setting up shares?  did i miss something?

Link to comment

man that stinks.  well, i changed the name of my post since the machine is not frozen anymore and the real problem seems to be the cache drive.  since i'm still quite the noob and i just built and set up the thing last week, i'm not going to mess with any beta.  i believe 4.7 is the current stable release.  and as far as far as the cache drive, I'm just going to forget it for now it seems like it just a problem. i can manage with the slower write speeds to the tower.  and 'naxiand' thanks again!

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...