Jump to content

[SOLVED] new file perm issue - 5.0b11


dandirk

Recommended Posts

Ok I recently upgraded from 4.5-> 4.7 -> 5.0b11   Thought I followed the directions to a T.

 

I seem to have permission problems with new files added via user share or direct disk.  Only the root group and "Console and webGui login account" have rights.  From what I read and assume is that the nobody account should be listed instead of "Console" (it is for all files after I run (or in my case) re-run the new perm script.

 

I can add/delete/move files file from my windows PC.  But my other box linux XBMC cannot seem to read new content until I run new perms script again.

 

I don't have any security setup and don't believe I ever have... the only user to show up in the users section is root.

 

I have tried:

 

  • Re-run the new perm script (a few times, it fixes issue after I copy files over, but not new files
  • Deleted the config/pwd and config/smb files, re-run new perm script
  • Add the nobody acct in the users section, user does not show up
  • removed user share, rebooted and created new
  • deleted all windows drives
  • Tried various folders etc to see if limited to certain folder... but issue seems everywhere.

 

I have only round one other post with similar issue then mine, but he was using 2 shares (http://lime-technology.com/forum/index.php?topic=8725.0).

 

Any thoughts?

syslog.txt

Link to comment

No none really... I am just running the script everytime I add files...

 

I figure next step is to just delete the whole flash and start over... I assume the new install will still see and array... I will just have to resetup user shares.  Going out of town this weekend so no unraid work or BF3:)

Link to comment

a bit more info but no headway so far...

 

stopped array, deleted files on flash, replaced with new 11.0b12 files.  Reboot and resetup of drives/user share - still no go it seems, the root account is owner (I assume it is supposed to be nobody).

 

ok so I am trying to figure out what is happening... with my limited knowledge and google help... came up with the ls -l command!!!

 

Rights after running the script are: drwxrwx  nobody/users

Rights after creating a new file are: -rw-rw  root/users  (-rw difference is due to it being a file rather then folder)

 

ok so I then set a password for the root account... could not access my shares/drives with out root credentials.

 

I then created a new account, logged into \\tower with the new credentials, created a new file... Well ownership changed to the new user, makes sense but isn't is the nobody acct supposed to own all new files?...

 

Still working on it... going to revert to 4.7 sometime to see if that "resolves" the issue and go from there.

 

 

 

Link to comment

ok solved the problem, as it were the issue was related to the post I linked in the OP.

 

As far as I can tell... Windows seems to cache blank passwords longer then expected (reboot should clear) and possibly some sort of glitch in UNRAID in conjunction.  As in the post above, I set a password to root, could not access my shares (get a login prompt) even though still had public security on (in 4.7 this config worked).

 

I set the root password back to null, still receiving a credential prompt for my disks/shares.  Logged in with user "nobody" password blank (for win7 be sure to elect "other user" went providing creds)...  Then everything worked fine, new files were owned by nobody, was able to change my root password and still have "public" access.

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...