Jump to content

Getting false (I think) "No space left on device" errors when renaming files


Recommended Posts

4 hours ago, Frank1940 said:

How are you trying to rename these files?  (If using command line, show the actual command that you are using to rename a specific file that fails.)

 

I've tried a couple ways. I'm trying to reformat the file names of a batch of 7 .mp3 files with:

 

find . -iname "*.mp3" -exec rename '[02-0' 2 '{}' \;

 

It worked for 3 of the files before spitting out the "No space left on device" for the other 4. On repeat runs of the command, I just get the "No space left on device" error without any further progress.

 

But I also tried in macOS (over SMB I presume?) in Finder. Even just making a single change to a single file name generates this error:

 

image.png.6fe8a0b5e057d8dca4e8dfa35a6b93c4.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...