Jump to content

Write performance is slooooooow...


sdumas

Recommended Posts

Hi Everyone,

 

I am using UnRAID 4.5.4 and I am having performance issues.

 

I just upgraded my case and my controllers thinking the controller would make a big difference - but no.

 

I have a Norco 4220 with the SuperMicro AOC-SASLP-MV8 on an Asus mobo P5K-E 2 Gig or RAM, that have 6 on board SATA ports and GB ethernet onboard working at 1 GB and connected on a Gig switch as well.(client is Gig as well). I have 12 drives in the case. I am not using user shares and I am not using a cache drive (obviously - no user share - no cache drive...).

 

Previously I had 3 controllers in the machine - 2 PCIe 1x "noname" Sil Raid controllers (converted to non-RAID) and one PCI Promise Sata 300TX4.

 

I have a Seagate 2 TB as the parity drive and a mix and match of other drives (WD 2TB Green, WD 1TB green, WD 1TB Blue and some Seagates as well).

 

My read rate is fairly good - I get anywhere between 30 to 60MB/sec

My write rate is ... technical term would be "sucks" at a rate of between 6 to 11 MB/sec.

(I have not seen an improvement from the 3 previous controllers to the new one)

 

To do my tests I use a 2 GB folder that contains pictures and I move it from a machine on the network to a drive on the server. I have tried copying to different drives on the server - some connected to the onboard controller and some the the SuperMicro controller. No big differences.

 

I tried the "acpi=off" switch on the append line in the syslinux file - no difference

 

I am sure I am missing something - when I see others have 60MB+ on write and I get 10% of that it kills me.

 

I connected with Putty and copied internally with MC from Drive1 (SAS port1 - Seagate 2TB) to Drive 11 (SAS port 8 - WD Green 2TB) and got an average of 9 MB/sec transfer rate

 

Any ideas or clever things for me to try? or is this normal and it is as good as it gets?

 

Thanks!

Link to comment

Sounds on the low side but 60MB+ is definitely on the high side unless you are running SSD's or using a cache.

I think the vast majority are around 20-30MB..

 

I have the latest black WD drive as parity and earx's as data drives and I get around 30MB.

So yes you should be aiming for more but 60 is way unrealistic without using a cache drive.

Link to comment

What is the model id of your parity drive?

What controller is it hooked up to?

What data drive and controller are you writing to?

 

These are all factors.

Putting parity on the fastest drive you can afford and on the fastest path will help with the speed.

 

With that PCI card, the fastest you can get locally is between 60-120MB/s with single drive access.

With two drives accessing it drops dramatically. However there is also a bottleneck on the PCI bus when accessing multiple devices.

 

Also with your 2TB drives, if they are advanced format drives, some wd EARS drives need a jumper or need the latest versions of unRAID to be used to align the partition correctly.

 

Try using Teracopy to copy your data and benchmark the transfer speed.

Allot of times I'l burst from 30-45MB/s and then drop to around 20-25Mb/s around the tail end.

Link to comment

Keep in mind that if your test folder contains a lot of small files you will get slower that usual speeds.  I'm not saying that is the whole problem.  I just think you should try a larger contiguous file.  A movie file or a large disk image.  Test that and see what your speeds are.

Link to comment

I only have problem with write performance...

 

these are my drives

 

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:00:1f.2-scsi-0:0:0:0 host4 (sdj) ST32000542AS_5XW1X61B

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:00:1f.2-scsi-0:0:1:0 host4 (sdk) ST32000542AS_5XW1CS31

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:00:1f.2-scsi-1:0:0:0 host5 (sdl) WDC_WD10EADS-00L5B1_WD-WCAU47013249

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:00:1f.5-scsi-0:0:0:0 host6 (sdm) WDC_WD1001FALS-00J7B1_WD-WMATV1537250

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy0:1-0x0000000000000000:0-lun0 host0 (sdb) ST32000542AS_5XW1EA6V

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy1:1-0x0100000000000000:1-lun0 host0 (sdc) WDC_WD10EARS-00_WD-WCAV55369529

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy2:1-0x0200000000000000:2-lun0 host0 (sdd) ST3500320AS_9QM140N5

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy3:1-0x0300000000000000:3-lun0 host0 (sde) WDC_WD10EALS-00_WD-WCATR0665675

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy4:1-0x0400000000000000:4-lun0 host0 (sdf) WDC_WD20EARX-00_WD-WMAZA5142265

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy5:1-0x0500000000000000:5-lun0 host0 (sdg) WDC_WD10EARS-00_WD-WCAV59435488

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy6:1-0x0600000000000000:6-lun0 host0 (sdh) WDC_WD20EARX-00_WD-WCAZA8032157

Oct 20 10:03:03 HTPCRAID emhttp: pci-0000:04:00.0-sas-phy7:1-0x0700000000000000:7-lun0 host0 (sdi) WDC_WD10EADS-00_WD-WCAU47012923

 

Parity drive is ST32000542AS (Seagate 2TB) and it is connected directly on the motherboard ports.

 

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...