Jump to content

While copying files, mid-transfer, I lose permission to write to array


Recommended Posts

I've been installing unRAID successfully for several days, and had started copying files from individual hard drives attached to my Windows machine to the unRAID server. I had successfully precleared 4 WD20EARS disks and 1 WD15EADS disks with zero errors and everything has been going fine.

 

To speed up loading initially I have been running without a cache drive or a parity drive, intending to add both once the initial data had been loaded. I had have loaded around 1.3 TB of data without problem.

 

I was copying a new batch of files in folders that was about 350 GB. Windows indicated that it was very close to the end of the transfer - saying it had about one minute left when it suddenly gave me an error from Windows (I didn't catch the description of the error at that point, assuming it was something simple.) I cancelled the operation, but when I tried to then copy a single file to the array it said "You need permission to perform this action".

 

Now Windows is telling me that I don't have permission to copy anything to the array. The user share is still mounted, and mapped to a network drive. I can't rename or copy files that are already on the share, either. Apparently I only have read-only permission.  I also notice that many of the folders it copied are blank - just empty folders - even though the copy dialog from Windows indicated that I was very near the end of the copying operation. There were 1123 files to be copied in 84 folders, and the media share indicates that only 445 were copied in 83 folders. I tried to play one of the video files in that batch from the array and vlc wouldn't play it. It would however, play video files that had been copied earlier.

 

I went to web interface and discovered that one of the disks appears to have had over 19,000 errors and is showing at a temperature of 0 degrees. I've attached an image of the disk status page. Since disks 3 through 5 had just been added immediately before this operation, were empty, and I am using the "High-Water" method, all the files copied in this last batch had been placed on this drive by unRAID (Not by me. I didn't copy directly to the disk share).

 

I'm not at all sure how to proceed. I'm hesitant to stop and restart the array, reboot the unRAID server, and or reboot the PC fearing I could make something irreparable. (BTW I have a preclear on another drive that's been ongoing for about 7 hours so I don't want to reboot on a whim but will do so if so advised.)

 

Do I have a bad drive (even though it precleared without error, just today) and if so should I just remove it. Or is this some artifact of a permission issue that might go away with a reboot. Suggestions much appreciated.

 

disk_array.JPG.446810553e030f3bf037ecb3c3a25db6.JPG

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...