Jump to content

DirSyncPro Log

Go to solution Solved by nigelt,

Recommended Posts


I have been unable to find a solution to this issue.


Since I rebuilt my unraid server, I have been unable to use DirSyncPro docker. I have deleted and reinstalled countless times.

Every time I try to configure a Job, I get a problem where it is unable to write to a logfile. I have tried various paths, ensured write access to those folders.


the log from starting DirSyncPro is as follows:


lease read the 'License.txt' file accompanying this program.

ERROR: Log file '//DirSyncPro.log' could not be created.

ERROR: Log file '//DirSyncProJobset.log' could not be created.

Exception in thread "main" java.lang.Error: java.lang.NullPointerException
        at dirsyncpro.tools.Log.writeLog(Unknown Source)
        at dirsyncpro.tools.Log.writeToAllLogs(Unknown Source)
        at dirsyncpro.tools.Log.print(Unknown Source)
        at dirsyncpro.tools.Log.printMinimal(Unknown Source)
        at dirsyncpro.gui.mainframe.MainFrame.initConfig(Unknown Source)
        at dirsyncpro.DirSyncPro.main(Unknown Source)
Caused by: java.lang.NullPointerException
        ... 6 more


Unraid 6.12.8


Anyone have any thoughts?



Edited by nigelt
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...