Jump to content
We're Hiring! Full Stack Developer ×

[TEMP FIX] add_fsevent: unable to get path for vp...


ajax3712

Recommended Posts

Hello all,

 

For the Mac users out there, I was wondering if any of you have been seeing this in your Mac's console logs after copying over a file to the unRAID server via AFP?  

 

11/4/11 3:58:28.000 PM kernel: add_fsevent: unable to get path for vp 0x1b3eecb8 (09 - Kiss.mp4; ret 22; type 
11/4/11 3:58:28.000 PM kernel: add_fsevent: unabled to get a path for vp 0x1b3eecb8.  dropping the event.

 

A symptom is that immediately after the copy finishes, the file disappears from unRAID.

 

I'm using Lion & a cache drive in my unRAID.  I've tried reiserfsck on my cache drive, and no errors were found.  

 

I don't seem to remember seeing this before adding the cache drive, so I might try setting the share not to use cache, but in the mean time, I'd thought and ask the forum...  I've posted my syslog and another problem that I'm experiencing is an explosion of .AppleDouble related duplicates.  I'm in the process of deleting them and trying to configure my mac not to write them in the first place (using BlueHarvest, a pref pane), but in the mean time apologies for having to wade through all those dup messages.  If necessary, I can post a cleaner log in the near future after I'm done with all the dup pruning...

 

Thanks!

 

[Edited Title to no longer say solved.  Deleting the .AppleDouble files is the fix until it happens again]

syslog-2011-11-04.txt.zip

Link to comment

Try deleting all of the .apple files.

 

That seemed to have done the trick.  I haven't seen files disappear yet since I've deleted all the .AppleDouble files/dirs.  I'm still curious as to what caused this and if deleting the .AppleDouble files is a one-time fix (i.e. will this reoccur at a later point in time?). 

 

Oh well.  I'm good for now.  :)

Link to comment
  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...