Jump to content

Very high shfs CPU usage! -> Turns out my speed governor isn't working!


Recommended Posts

Right,

 

Found out why my speeds were being so hopeless now.

 

go script:

 

/sbin/modprobe powernow-k8

/sbin/modprobe cpufreq_ondemand

for config_file in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor; do

    echo ondemand >$config_file

done

 

When this is enabled, speeds drop to either 800/1200/2400/3000Mhz.

 

Now when it's transcoding it jumps up to 3000mhz, but when I'm transferring files, it doesn't sit at 3000mhz and limits my transfer speeds.

 

When it's set at:

ondemand: 10-30MB/sec

performance: 50+MB/sec!

 

Why is PS3MS hitting 3000mhz and shfs isn't!?

 

Any help would be great, I'm going to leave it in performance mode until I can get speedstep back :(

 

Link to comment

Edit: Nevermind!

 

Some testing:

 

Left picture is to a cache drive enabled share, right picture is to a parity only share.

 

Speedup % is 60.

 

sampling_down_factor = 1

sampling_down_factor_1.pngp_sampling_down_factor_1.png

 

sampling_down_factor = 10

sampling_down_factor_10.pngp_sampling_down_factor_10.png

 

sampling_down_factor = 50

sampling_down_factor_50.pngp_sampling_down_factor_50.png

 

sampling_down_factor = 100

sampling_down_factor_100.pngp_sampling_down_factor_100.png

 

Max speed = performance mode

performance.pngp_performance.png

 

The drops are due to the NIC driver falling over :(

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...