Jump to content

[Solved] Help writing to shares/disks


W1nks

Recommended Posts

Hello, I just set up my first Unraid server and have run into a problem.  I can't write to my shares or disks.  I set export to "Yes", security to "secure".  I gave root "Read/write" but I can't get it to work.  I am using Windows 7 64 bit and it does not ask me for log in credentials.  I even tried setting it to public and that didn't allow me to write to it either.  I am using version 5.0-beta13.  Also, why is private greyed out in the security options for the share?  From what it looks like here that is the option I need selected for what I want to accomplish.

 

Another question I have is can I set certain shares to be not readable by certain users?

 

Thanks.

 

EDIT - Note: The Parity-Sync is still running from the initial setup if that affects anything.

Link to comment

Thanks. It doesn't say anything next to "Private" but I will just wait until the parity sync is done and try to stop the array.  I just read that you could still transfer files and what not while that was going so I figured I would start setting things up.

Link to comment

Yes, I believe you want Private. Public means everyone has read access so your W7 box accesses read-only and then it's was too "stupid" to ask for the login when you tried to write. Private means no access unless you log-on so you will have to first log-on before you can either read-only or read-write.

 

I have no idea why the Private is greyed out though. As already suggested, maybe try setting it with the array stopped? Or maybe try to put in the users first and then set it? Or possibly there is some other setting you need to do, like create other user accounts besides root first? I'm not sure, I don't run the beta.

 

Note that you likely have to reboot the W7 machine any time you change the security settings. Note also that as a minimum you have to log-off or else the next person to use the W7 machine will still have access. You should test it, because you may actually have to reboot for the log-in to be forgotten.

 

Peter

Link to comment

It's still not allowing me to select private or write to my shares.  And when I take the array down it takes away my shares.  I says the array needs to be running to configure the shares.  Here is a screenshot of what the configuration looks like.

 

bVFS4.png

 

Do you see anything set up wrong?

 

More screenshots:

 

Qi9Uu.png

 

http://i.imgur.com/F1YZk.png

 

http://i.imgur.com/ImlAW.png

 

http://i.imgur.com/UqmH5.png

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...