Jump to content
nxtiak

VSFTPD keeps reverting to default

4 posts in this topic Last Reply

Recommended Posts

I'm trying to setup VSFTPD and whenever I reboot my unRAID server to have the changes apply, the vsftpd.conf file inside /etc/ reverts back to original.

I'm a unix n00b.

 

Any ideas? Or know of a command to restart the vsftpd service to apply the new settings I changed?

I've googled commands but none work on unRAID.

Share this post


Link to post

Unraid boots and installs everything into the RAM of your computer. So /etc/vsftpd.conf is in RAM too. On reboot all changes will be lost. You have to create a vsftpd.conf with your changes on your flash drive and add a line to your go file, that replaces the /etc/vsftpd.conf with your version on the flash. This will then happen on every reboot and restore your settings.

Share this post


Link to post
On 6/7/2014 at 1:41 PM, SlrG said:

Unraid boots and installs everything into the RAM of your computer. So /etc/vsftpd.conf is in RAM too. On reboot all changes will be lost. You have to create a vsftpd.conf with your changes on your flash drive and add a line to your go file, that replaces the /etc/vsftpd.conf with your version on the flash. This will then happen on every reboot and restore your settings.

Sorry to bring up a very old post. But I did not find anything else. You can attach the code you recommended there under the go file?

Share this post


Link to post
Posted (edited)

@abeksis

Sorry for the delayed answer. I receive no more direct notifications of the thread it seems. First you copy your modified vsftpd.conf from /etc/ to a folder of your flash drive. You could use mc (midnight commander) in the console or a direct command could be:

cp /etc/vsftpd.conf /boot/config/vsftpd.conf

Afterwards you edit your go file on the flash. In the console you can use nano.

nano /boot/config/go

There you add a line, that will copy the file back from the flash each time your server starts.

cp -f /boot/config/vsftpd.conf /etc/

Afterwards you need to remember to copy the vsftpd.conf to the flash each time you make changes to it, or they will be lost after a reboot, as the file on the flash is still unchanged. Alternatively make the changes directly on the flash and copy the file from there to /etc or reboot to activate them.

 

Edited by SlrG
typo

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.