Jump to content

SlrG

Community Developer
  • Content Count

    506
  • Joined

  • Last visited

Community Reputation

20 Good

About SlrG

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. You can download older versions and their dependencies manually from my github account. Download the following into /boot/config/plugins: https://github.com/SlrG/unRAID/raw/87f31b9a223fd2f2b6b414207a2ab5204c1003f8/Plugins/ProFTPd.plg Create a new directory /boot/config/plugins/ProFTPd and download these into the new dir: https://github.com/SlrG/unRAID/raw/87f31b9a223fd2f2b6b414207a2ab5204c1003f8/AppSupport/ProFTPd/ProFTPd-SlrG-Control-1.5.tar.gz https://github.com/SlrG/unRAID/raw/87f31b9a223fd2f2b6b414207a2ab5204c1003f8/AppSupport/ProFTPd/ProFTPd-SlrG-Dependency-1.5_x64.tar.gz Afterwards a reboot of your server should install the older version of the plugin. The new version will show as update under Plugins and in the plugins settings afterwards however. Make sure you have no auto updates enabled and exclude the old version check of it from the "Fix Common Problems" plugin if you have that running. I didn't test it today, but I think that are the required steps. If it does not work, please report back.
  2. @LSL1337 While I certainly understand your frustration that this problem is not yet solved, things are not always as easy to fix, as a normal user might think. It probably won't help to discourage the author even further by being rude. If you know how to solve the problem, please provide a patch or pull request and the author will probably check and accept it. If you don't, please try to be kind, encouraging and understanding, that this plugin is developed in the free time of the author without monetary compensation (at least I think it is). @bonienl I don't have this problem myself, as I don't own NVME drives, so I don't really know, what I am talking about. But if the problem is recognizing if NVME drives are present and which ones they are, it might be a solution to let the user choose drives to be excluded from a list. What do you think?
  3. @wgstarks When trying just now, it works fine in the built in terminal when using .bash_profile.
  4. Copy the .bash_profile to your flash (/boot/config/) and add the following line to your go file: ln -sf /boot/config/.bash_profile /root/.bash_profile This will create a link overwriting the original file and pointing to the new one on the flash. Changing something in the original location will be put on the flash automatically and thus survive a reboot.
  5. I see nothing, that would help to solve the problem. Sorry. I would start with the base configuration and check if it works with plain ftp and basic settings locally. Then I would try to enable tls and check locally. Only then I would try to make it work externally. If it is the exact same configuration and router as on your system it should obviously work in theory. But there must be some difference in the setup of the unRAID box or router or other interference, as it clearly does not work. Sadly the log doesn't tell me why it fails.
  6. I know I will sound disrespectful, so please forgive me, but I'm a bit burned out by answering the same questions over and over. The info you are requesting is one page back or at least a link to it. Also the topic is searchable and using the keyword SFTP would have given you the needed results. Here is a direct link to the post. On how to change the port: You could do this in the proftpd.conf file, but I recommend staying on the default port for the server and setting up a port forwarding rule in your router which will forward an external port of your choice to the internal default port.
  7. @zonik Well, there are IMHO some errors in your file. Only #!/bin/bash is correct, the second and third one without the hashtag should to be removed. Also you are trying to mount --bind from /media which should be /mnt instead. Probably the folder anime gets created and then the execution of the mountfile stops because of the errors. Therefore nothing is mounted into the anime directory and it stays empty. It should look like this: #!/bin/bash # put your commands for creating mount points and mounting here # they will be executed when the array starts # e.g.: # mkdir /mnt/cache/FTP/movies;mount --bind /mnt/user0/movies /mnt/cache/FTP/movies # Mounts just media for read only # Directory Structure mkdir /tmp/FTP/ mkdir /tmp/FTP/Media mkdir /tmp/FTP/Media/anime;mount --bind /mnt/user/Media/Anime /tmp/FTP/Media/anime mkdir /tmp/FTP/Media/movies;mount --bind /mnt/user/Media/Kvikmyndir /tmp/FTP/Media/movies # Mounts for Apps/Tools/ISO ect # Apps and Tools are Read only # Uploads are Read/Write mkdir /tmp/FTP/Uploads;mount --bind /mnt/user/Media/ftp/ /tmp/FTP/Uploads/
  8. @zonik Well, this is not new. It was the same for the user tester in the logs you send me before. Please be sure to check out my tips one post above yours.
  9. The user definition looks fine. In your logs the user tester has problems to access his "home directory". Please check that /tmp/FTP really exists, when you try to login. Also make sure it hast the correct access rights. For that you can use the newperms command: newperms /tmp/FTP When testing on my server it works fine if I create a directory /tmp/FTP and jail an user into that. So in theory it should work for you too.
  10. @zonik Installation and start of the plugin looks fine. You have anonymous users connecting, which does not work. Then there are users where no home directory is available. And lastly you have users where the password is not recognized. How do you setup your users? Did you add the keyword ftpuser in the comment field? Optional: Did you give a working homepath to jail them into after this keyword separated by a space? And did you restart the plugin after defining your users? Some passwords with special chars may not work. Start with simple ones and if it works increase the complexity. Also a security notice: It is not recommended to connect your unRAID servers services directly to the internet. It is better to use a VPN to connect to your home network and access the unencrypted ftp service from there. If you are set on making it public, make sure your external port is not 21, as that is the first to be hit by malicious crawlers. Research how to enable encryption when you get the baseline working. Some pointers are in this thread.
  11. @abeksis Sorry for the delayed answer. I receive no more direct notifications of the thread it seems. First you copy your modified vsftpd.conf from /etc/ to a folder of your flash drive. You could use mc (midnight commander) in the console or a direct command could be: cp /etc/vsftpd.conf /boot/config/vsftpd.conf Afterwards you edit your go file on the flash. In the console you can use nano. nano /boot/config/go There you add a line, that will copy the file back from the flash each time your server starts. cp -f /boot/config/vsftpd.conf /etc/ Afterwards you need to remember to copy the vsftpd.conf to the flash each time you make changes to it, or they will be lost after a reboot, as the file on the flash is still unchanged. Alternatively make the changes directly on the flash and copy the file from there to /etc or reboot to activate them.
  12. @zonik I will need the system logfile syslog then. Please upload it to a cloud storage and send me a private message with the link. Make sure it is not after a fresh start of your server, but after trying to login via ftp. Which client do you use to connect? What error message does it give when trying to connect?
  13. @zonik Please read what JaY_III posted. I think it will help you to solve your problem.
  14. @fluisterben As you can see in the default proftpd.conf I'm not additionally limiting the max users in any way. So if they are, this is a ProFTPd default setting baked into the server itself and not changeable by me. It is probably a security precaution to only allow one login per user. If you want to change it, you can use the MaxClientsPerUser number|none directive.