Jump to content

can't get ubuntu server to install


Recommended Posts

Just got my first unraid (6.0-rc3) box up and running and I'm now ready to try out vitalization.  I thought I would start out simple and install an instance of Ubuntu server 14.04.2 but I'm having some trouble.  I'm happy to do some reading and figure this out for myself, but I can't find anything that addresses my specific issues. Generally I can make it though most of the setup but it finally errors with a red screen that says "An installation step failed" at the step "Install the GRUB bootloader on a hard disk".


I know the VM manager has been evolving through the betas and is a work in progress but is there anywhere that describes all the parameters so I know what to pick?  I know I should pick "Ubuntu" for the OS, but should I choose Host Passthrough or Emulated (QEMU64)?  What machine should I pick, Q35 or i440fx?  What BIOS should I pick SeaBIOS or OVMF.  I have found some posts that say OVMF is only necessary when I want to do GPU passthrough.  I know that won't be the case when I'm installing the server version of Ubuntu.


I get some errors at the beginning of the install that say "mount: mounting /dev/vda on /media failed: Invalid Argument" and "umount: can't umount /media: Invalid argument".  Could they be related to the trouble I'm having with the install?


Again, I hope I'm not missing something simple.  I've tried all the combinations of configuration options I can think of but still get the same result.  Any help is greatly appreciated.


My configuration:

  • SuperMicro X10SLH-F
  • 16GB Memory
  • SSD Cache



Link to comment

Post a screenshot of your vmmanager setup for the vm. I have recently been playing around as well with Ubuntu VM. I have not had the issue you are having however. I chose host pass through with with Q35. Only option I had for the BiOS was SeaBios. Did you select the Ubuntu template where it changes the icon to the Ubuntu emblem? Did you setup the img file? How big did you make it?

Link to comment

Your question about size of the disk prompted me to reconsider that.  I had been creating 2 GB disks.  Just out of curiosity I tried 10 GB.  It worked with no issues!  With 2 GB the installer defaulted to creating a separate /home partition, and with 10 GB it didn't, don't know if that's related minimum requirement for disk space on Ubuntu server is 1 GB, wonder why 2 GB failed? 


Anyway I included the screenshot for reference.  The only templates I see are "Custom" and "XML Expert".  It does change the icon to Ubuntu's when I pick "Ubuntu" for the OS though.  I thought it was strange that those were the only two options.


I admit I'm late to the party with visualization.  This is the first version of unraid I've used and have never had to configure vm's manually.  Is there any guide that explains all the different choices for the configuration?  Like I said before, I don't mind doing the research, but I've looked and haven't found anything specific.  I'm spoiled by the folks in these forums, it's easy just to ask my questions here.


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...