Jump to content

Disk shown as faulty yet passes all checks?


Harblar

Recommended Posts

Ok, So I've been spending most of the day trying to do a hardware upgrade and I kept running into problems with the array starting, unmountable disk, 10-15min before the webui would be accessible, etc...  Finally said to hell with it and put the old mobo back in. Everything came back and worked completely as normal, except for disk 2...  It's showing as Faulty (with a read X) on the Dashboard page yet shows a green thumbsup in the Smart Row.

I stopped the array and started it back in maintenance mode and ran a reiserfsck via the Disk 2 Settings page in the webui. it came back clean with no corruptions. I ran a SMART short test and that came back completely clean too. There are no read or write errors that can find anywhere on the webui. I'm currently running the extended SMART test, but if that doesn't help anything, then I'm going to be at a complete loss as to what to do next. 

 

I do happen to have a spare disk I could swap in and do a rebuild on, but I'd like to try to get the current one working correctly if I can.

 

As for the hardware upgrade... I'm not really sure what the issue was. I recently did a completely new build of my desktop, which moved my old desktop to my HTPC, and, in turn, the old HTPC to my unRAID... At least that was the plan.  I hadn't really had any issues with the HTPC, but it sure didn't want to play nice with unRAID!  lol On that front, I think I'll just start buying and shelving approved components for a Good upgrade this summer. (I really need a better case solution than the one I currently have and this would be a good excuse for a total overhaul.)

 

Anyway, in the mean time, my current build is working fine, other than that one disk. Any thoughts?

Link to comment

If its still showing a red-x, then if you want to use that disk that you're sure is good, then you've got to stop the array, unassign the disk, start the array, stop the array, reassign the disk, and let it rebuild.

 

Anytime a write operation fails to a disk, unRaid will red-ball it.  In your case, maybe it was just a crappy connection.

Link to comment

It's just a 1TB drive, so it'd probably be the first drive I replaced during an upgrade anyway. It just confuses me is all... I'm about 20% through the Extended SMART self-test. See if that sheds any light on it.

 

What's weird is that, after I first upgraded to unRAID 6 a month or two ago it would show the Orange triangle in the SMART status row on the dashboard. Everything else read clear and the only hint of anything wrong I could find was a "Current Pending Sector" under attributes, yet nothing that really looked wrong about it. It was showing the redball and "emulating" the data on that disk as of this morning and did so before swapping the mobo, after the swap, and after the return to the old mobo. Maybe the SATA cable for that drive went bad or something? That'll be my next test if the Smart test comes back green.

Link to comment

and.... I'm starting to think the drive is just plain old toast.  I've been running the extended SMART test since about the time I made the original post here and the progress seems to be stuck at 90% complete. Think I'm just going to pull it, shove the new drive in, and rebuild it over night. 

 

Also think I'm going to invest in a new case. I've got a rack mount case at the moment, but it is a gigantic pita to actually swap out drives. Think I'm just going to get a decent tower with nice easy access (either a full set of 5.25's down the front I can shove some hot swaps to, or a nice corsair with the side mountable, modular drive bays. just bought a 780t for my desktop rig and LOVE the amount of space/airflow the thing has! No qualms about buying a similar one for my unRAID server.)

 

Anyway... I'll post back with my findings after the new drive is mounted. :-)

Link to comment

Ok... So I'm finally back up and running!  I went ahead and did the preclear procedure this time around (Honestly never done it before... Not much of a linux expert and didn't know much about it.)  Holy freaking crap that took forever!  27 hours to for a single pass on a 1TB drive!  While I was waiting I did some reading. Some of you all like to do as many as 3 passes!?!?!  I get that it's a good way to assure you that a disk is functioning correctly before loading it up with a bunch of important data, but dang! That'd be close to a month to triple check a new 8TB drive!!  I Know I could RMA a defective drive quicker than that. Then again, I'm using mine primarily for media storage. A busted drive (especially right off the bat) isn't super critical for me, but still...Wow!  lol

 

Anyway... the light is green, so unRAID's clean! :-)

 

Next on my list, I'll be moving my whole setup to a new case next weekend.  Went ahead and ordered a Corsair 760T. All of the modular drive bays (with the exception of the three 5.25" bays)are side loadable and accessible from the back side. Next best thing to a hot swap dock. If I load a 3 - 4 ICY-dock into the 5.25's I figure I can get as many as 16 drives into it and still have tons of space for airflow and cable management. I'd also have more than enough space for 4-5 SSD's in addition to that. Should work a whole lot better than the POS rackmount case I've got it in now. ;-)

Link to comment

Don't know what about your particular hardware made preclear so slow. My rule-of-thumb is 10 hours per TB per cycle, usually a little less since larger drives are typically faster. Maybe your smaller drives are slower but I wouldn't think that much slower. Probably some sort of controller bottleneck.

Link to comment

Very well could be. I'm running fairly old hardware. Core 2 duo, 6GB ram, etc...  3 or so of my drives are hooked up through a cheap 6Gbps pci-express addon card and the rest are using onboard Sata 2 ports. I've not noticed too much slowness through them in terms of transferring files and streaming media, but it probably wouldn't show there a whole lot. I'm due for a good upgrade to the hardware on my server, but can't afford to go all in at once, hence starting with a new case. I'm going to try to figure out the rest of the components over the next week or so here and then just buy a few pieces here and there (watching for sales) till I've got everything I need.

 

I've actually got a fairly nice, for me, upgrade sitting on the shelf right now. In fact, that's the one I was trying to get running that led to most of my trouble (and the start of this thread) in the first place.  Obviously there was something about it that unRAID plain did not like. lol  Eitherway, for my purposes I think I'd benefit more from going to a good quad core i7 of some sort. That'd give me more than enough power to handle multiple HD streams and/or transcodes.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...