Transfer speed suddendly drops from >100MB/sec to 20MB/sec.

Recommended Posts

I'm on 6.2.0-beta21, but I may have seen something similar on an earlier build.


I'm doing some large copying (mostly large files) from WS to unRAID (no parity) and initially the transfers go at >100MB/sec.  Last night I copied 400GB and the network throughput was very good.  Then suddenly, in the middle of the copy job, throughput went to crap, dropping to 10-20 MB/sec.  I stopped the copy and did some testing with a large file from my local SSD to unRAID, and the speed remained slow.


I rebooted unRAID and the problem persisted.  It was only when rebooting the workstation that the problem went away and I was aback at >100MB/sec again.  Restarted the copy job and after about 20 minutes at high speed, it went to crap again.  Restart unRAID had no effect, but restarting the workstation fixed it (again).


This is 100% repeatable.  I tried different cables, a different hub, removed smb-extra.conf .... nothing worked.

Link to comment

I may have found the fix.  It is a configuration option on the Workstation NIC:  Large Send Offload.


On my Intel 82579V GigE NIC, the option under Advanced Options of "Large Send Offload Version 2 (IPv4)" was set to enabled.  I changed it to disabled and rebooted.  Been good as gold since then.

Link to comment

Note to others: you might also want to disable "Large Send Offload Version 2 (IPv6)" too. Your PC will disconnect from the network momentarily after the setting change.


The option is under "Configure" button under adapter properties (see screenshot).


Some more information on why you might want to disable LSO: Link

Apparently it says Intel adapter is one of the worst offender. :o


Link to comment

Didn't seem to correct my situation - I'll do some more testing tonight though. Graphs look the same as my initial post. I'll try to watch both the windows network speed in the VM and the server memory and disk usage at the same time, and see how it goes...  at least this is a path to try. ... thanks, cheers.

Link to comment
  • 1 month later...

Due to bubbaQ's discovery, I created a 'tip' for it on the Tips and Tweaks wiki page, and Dan added it to the Tips and Tweaks plugin.


It appears to only affect certain NIC's that have execution offload capabilities, primarily Intel NIC's.  The behavior is typical, on boot all networking is fine, but occasionally during large file transfers, network speed will suddenly drop dramatically (doesn't stop though, just much slower).  It can only be restored by rebooting.  I don't know whether disabling offload should be automatically set in unRAID, probably need more testing, but there are numerous reports online where it helped (not just an unRAID issue).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.