Jump to content

Win 10 VM unresponsive after being idle


Recommended Posts

Hi all,


I've been struggling to get a Windows 10 VM up and running in my UnRaid for a bit now.  The first couple of issue I had can be found here GPU in R710 Server  I got past those issues and have the VM starting up and being able to pass through the GT730 I've installed.  The problem I'm having now, is that once I start the VM I'm initially able to log in with RDP, Teamviewer or Splashtop.  But after I log out and the VM is idle for a bit (normally 5 to 15 minutes) it becomes unresponsive.  Ping's to the machine time out, attempts to remote connect to it fail, I haven't hooked up a monitor yet to see what output I get locally (if any), but can if needed. 


I've tried the VM using just VNC and still have the same results.  I did some searching but didn't find anything that stood out on the forums.  My XML and VM Logs are below.  Any help would be greatly appreciated.





2017-05-31 18:01:43.781+0000: starting up libvirt version: 2.4.0, qemu version: 2.7.1, hostname: UNRAID-RACK
Domain id=1 is tainted: high-privileges
Domain id=1 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)
2017-05-31T18:28:49.982564Z qemu-system-x86_64: terminating on signal 15 from pid 6586
2017-05-31 18:28:51.383+0000: shutting down, reason=destroyed
2017-05-31 18:29:16.941+0000: starting up libvirt version: 2.4.0, qemu version: 2.7.1, hostname: UNRAID-RACK
Domain id=2 is tainted: high-privileges
Domain id=2 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)




<domain type='kvm' id='2'>
  <description>Windows 10 Enterprise - SeaBIOS</description>
    <vmtemplate xmlns="unraid" name="Windows 10" icon="windows.png" os="windows10"/>
  <memory unit='KiB'>8388608</memory>
  <currentMemory unit='KiB'>8388608</currentMemory>
  <vcpu placement='static'>4</vcpu>
    <vcpupin vcpu='0' cpuset='9'/>
    <vcpupin vcpu='1' cpuset='10'/>
    <vcpupin vcpu='2' cpuset='21'/>
    <vcpupin vcpu='3' cpuset='22'/>
    <type arch='x86_64' machine='pc-i440fx-2.7'>hvm</type>
  <cpu mode='host-passthrough'>
    <topology sockets='1' cores='2' threads='2'/>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/cache/domains/Kodi/vdisk1.img'/>
      <target dev='hdc' bus='virtio'/>
      <boot order='1'/>
      <alias name='virtio-disk2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/iso/virtio-win-0.1.126-2.iso'/>
      <target dev='hdb' bus='ide'/>
      <alias name='ide0-0-1'/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    <controller type='usb' index='0' model='nec-xhci'>
      <alias name='usb'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
    <controller type='pci' index='0' model='pci-root'>
      <alias name='pci.0'/>
    <controller type='ide' index='0'>
      <alias name='ide'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    <controller type='virtio-serial' index='0'>
      <alias name='virtio-serial0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    <interface type='bridge'>
      <mac address='52:54:00:37:a8:b8'/>
      <source bridge='br0'/>
      <target dev='vnet0'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    <serial type='pty'>
      <source path='/dev/pts/0'/>
      <target port='0'/>
      <alias name='serial0'/>
    <console type='pty' tty='/dev/pts/0'>
      <source path='/dev/pts/0'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    <channel type='unix'>
      <source mode='bind' path='/var/lib/libvirt/qemu/channel/target/domain-2-Kodi/org.qemu.guest_agent.0'/>
      <target type='virtio' name='org.qemu.guest_agent.0' state='connected'/>
      <alias name='channel0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    <input type='tablet' bus='usb'>
      <alias name='input0'/>
      <address type='usb' bus='0' port='1'/>
    <input type='mouse' bus='ps2'>
      <alias name='input1'/>
    <input type='keyboard' bus='ps2'>
      <alias name='input2'/>
    <graphics type='vnc' port='5900' autoport='yes' websocket='5700' listen='' keymap='en-us'>
      <listen type='address' address=''/>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x06' slot='0x00' function='0x1'/>
      <alias name='hostdev0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
  <seclabel type='none' model='none'/>
  <seclabel type='dynamic' model='dac' relabel='yes'>


Link to comment
On 5/31/2017 at 4:01 PM, Aerowinder said:

This one has happened to me before.


Did you try disabling automatic sleep in the VM under windows control panel?



I did, I just double checked it and it was off in the only two locations I could find it.  I set it to 5 hours and then back to never, maybe it was just an issue with Windows, but I'll have to just try it and see.



Update:  Still no luck, with Sleep set to never in the power plan options and in the main power settings menu, I still have the same issue.


Update 2:  Still had video on the VM even though it wouldn't respond to ping's or remote connections, but didn't have a keyboard and mouse passed through yet to see if it was responsive, looks like it might be something with the network adapter. 


Update 3:  Not sure what the problem was, I ended up building a new VM using a new Windows 10 ISO and using OVMF.  This time I didn't have any of the error code 43 issues with my GPU pass through and didn't have the weird unresponsive issues I was having if  the VM was idle. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...