Jump to content

[SOLVED] Windows 10 VM - VNC = Good :: GPU Pass-through = Bad


daquint

Recommended Posts

HI there,

 

Help!

I made a Windows 10 VM, following instructions from spaceinvaderone's windows 10 VM video - awesome vids!

 

After making sure my NVIDIA card was in a separate IOMMU group (setting Enable PCIe ACS Override: = Yes), Windows installed fine and got all my drivers set. Using VNC was (and is) working fine. I can connect and use Windows 10 via VNC- works great!


It seems when I try to pass-through my Nvidia Geforce 1060 or my on-board Intel gpu, the VM seemingly does not start up.

 

When i try to connect with TigerVNC viewer it just gives an error unable to connect to socket: Connection Refused (10061)

 

I got it to work once and was able to install my Geforce drivers (right after I set the GPU to onboard in bios) but since that first time, it hasn't worked

 

The things I have tried:

Created Windows 7 VM same symptom

Created Windows 10 VM with SeaBIOS

Set both video and audio passthrough devices to the nvidia card

Set bios GPU to onboard by default

Set Enable PCIe ACS Override to Yes - rebooted

Set my Syslinux Config with the line append intel_iommu=on vfio_iommu_type1.allow_unsafe_interrupts=1 pcie_acs_override=downstream initrd=/bzroot

 

I have attached my Windows 10 VM XML and my VM log - nothing seems out of the ordinary to my newb eyes...

 

Any other logs I should add?

 

any guidance would be appreciated. I can't stop until its working lol!

Windows 10 VM XML.txt

Windows 10 VM log.txt

Link to comment

Ugh - so after 36 hours of banging my head...

 

I plugged the GPU into a monitor and it was there, working. Probably was all along...

 

I am not sure how I connected once (with the GPU passthrough) but it turns out my firewall was blocking access.

disabled firewall and BAM.

 

Its working now - hopefully it sticks.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...