Jump to content

Cannot update/download any docker containers


AlexNathan345

Recommended Posts

Whenever I try to update (or download) any docker containers I get the following error message (this example is for the Emby container):

 

Error: Get https://registry-1.docker.io/v1/repositories/emby/embyserver/tags/latest: x509: certificate is valid for *.tvaas.com, not registry-1.docker.io

 

But the messages are the same for the other ones except for the repository link. I have no idea what this means or how to fix it - can anyone help please? Re-starting the dockers or the docker service didn't help.

 

Thanks!

Link to comment

Diagnostics are always a boon.

 

Try this.

 

Stop the docker service (settings - docker).  Then switch to advanced view.

 

Create a NEW docker.img file (give it a different name so we're not trashing the existing one if we need to go back to it) and try installing an app.  If that doesn't work, then try installing any plugin -> does that return any errors?

Link to comment

Stopping docker, creating a new image and then installing a docker (either from existing template or totally new one) doesn't work - I still get the same errors. However, installing a new plugin from CA or updating existing ones works fine (without errors).

 

Did the diagnostics file shed any light on the problem? Or do you think any installed plugins could interfere with docker? Perhaps ones that installed incorrectly (although they all seem to work)?

 

I have these plugins installed (all are the latest version):

CA Auto Update Applications
CA Backup / Restore Appdata
CA Cleanup Appdata
CA Resource Monitor
Community Applications
Dynamix Active Streams
Dynamix Auto Fan Control
Dynamix Cache Directories
Dynamix Local Master
Dynamix SSD TRIM
Dynamix System Information
Dynamix System Statistics
Fix Common Problems
Nerd Tools
Preclear Disks
SNMP
ssh Plugin
Statistics
SwapFile
Unassigned Devices

 

Nerd Tools has the following packages installed:

perl-5.24.0-x86_64-1.txz
python-2.7.13a-x86_64-2.txz

python3-3.5.2-x86_64-1.tgz
screen-4.4.0-x86_64-1.txz
subversion-1.9.5-x86_64-1.txz
tmux-2.5-x86_64-1.txz
unrar-5.4.5-x86_64-1.txz
utempter-1.1.6-x86_64-2.txz

 

Thanks for your help!

Link to comment

Thanks Squid for trying to help again. I tried the above without look - still the same problem I'm afraid.

 

Reading around it seems that to resolve this one can either re-create the certs which doesn't work on unRAID per command above, or to disable certificate checking altogether (docker --tlsverify=false - again doesn't seem to work on unRAID) which I'd be happy with but can't find anywhere to do this...

 

Very frustrating the whole thing as it just started to happen whilst I was on holiday and clearly hadn't done anything with the server.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...