Jump to content

I Need Assistance with Docker Container Mount Permissions (SOLVED)


Recommended Posts


I'm trying to mount a local unRAID appdata folder to the working folder in docker container jupyter/scipy-notebook. The container runs and works fine except my work is not being saved to my volume mount. I believe the problem has to do with incorrect values in the "Extra Parameters" section for the User Id and Group Id. I've tried 99 and 0 as values. Can anyone help me get this working? Your help is appreciated! Thanks!

Documentation for volume mounts on this image:



Host volume mounts and notebook errors

If you are mounting a host directory as /home/jovyan/work in your container and you receive permission errors or connection errors when you create a notebook, be sure that the jovyan user (UID=1000 by default) has read/write access to the directory on the host. Alternatively, specify the UID of the jovyan user on container startup using the -e NB_UID option described in the Common Features, Docker Options section





Docker Options for this Image:



My Configuration:




Link to comment


This topic is now archived and is closed to further replies.

  • Create New...