Jump to content

2 of 4 disks not being allocated anything at all?


Johnny

Recommended Posts

I had moved files around to make an empty disk in order to convert to xfs, which worked fine or so I thought. But weeks later I happened to notice my cache disk has 124 gig on it, and 2 of my 4 disks have no files at all, and no directory either. I would have expected to see my media/movies and /tv shows on there but they are blank. So they show as part of the array but are not being allocated anything at all. Before the xfs conversion I upgraded to a larger parity drive, those are the only two changes I have made.

 

What have I done wrong? What could I post to help someone help me?

 

Thank you!!

mainpage.jpg

globalshare.jpg

sharesettings_media.jpg

Link to comment

Under Share Settings for media, you have the "Use cache disk" set to 'yes'.  This means the media will be written to cache and only moved to the array when the mover is invoked.  Sounds like this is not what you wanted.  If you don't want them on the cache, then you can change this setting to 'no'.

 

I would first run the mover, which is located at the bottom of the page on the "Main" tab.  Then look at your disks on your array to see that the files have moved to where you expect them.  Then change the cache to "no".  Technically, I think you can change to "no" without doing the manual move.  I just like to see how stuff works.

 

If you want to keep the "Use cache disk" set to 'yes', then set the mover on a schedule.

 

Also, you didn't specifically say, but you should be seeing media files on the other two disks.  Are you?  It should just be the new media files that are sitting on the cache disk, waiting to be moved.

 

Also, under "Global Share Settings" I suggest you look at "Enable Disk Shares" settings and possibly set that to 'Auto'.

Link to comment

The other thing regarding your Share settings are:

  • you should set a Minimum Free Space value that is larger than the largest file you will have to stop mover trying to put files onto a disk without sufficient space and getting a failure during the attempt.
  • the value for Split Level over-rides Allocation method if there is contention for selecting the disk to be used.    Depending on the path to the files that are on the cache disk this may be forcing mover to try and put them on disks that are already nearly full.
Link to comment

How it worked before, was the cache stored the file until the mover activated at night, which it's set to 340am, emptying the cache disk. I want the cache to cache for faster downloads and offload the slower parity portion of it when I'm sleeping.

 

@doitmyselftoo No I'm seeing zero files on Disk 2 and Disk 3, Disk 1 and 4 between them have about 70 gb left. I've written lots of gb to the disks before I noticed it and it should have spread those files around (assumption). Disk 1 & 4 has file directories like Media, Music, etc, but Disk 2 & 3 are completely blank no file structure at all.

@itmpi Isn't 2000000 high enough I believe that was the guide setting for 2tb but it's been a long time since I set up unraid. What should I use for split-level setting? I just applied what the guide recommended, if I recall correctly I wanted a single movie folder to not be split up among disks, but I've created many new movies since then and I assumed it would spread the wealth?

 

Btw I can physically move files to Disks 2 and 3, they copy just fine but the mover is apparently ignoring all the disks, everything I thought I was sending to the disks for last couple months is still on the cache drive, I've manually invoked the mover and does nothing. /shrug

tower-diagnostics-20180706-0901.zip

Link to comment

[mention=10897]itimpi[/mention] is correct.  You should change your split level, so that the top level directory gets split to disks 2 and 3, since disks 1 and 4 are full.  Try changing to "Automatically split any directory as required."  Using "Automatically split any directory as required" could end up putting parts of the same media folder on more than one disk. This can be corrected.  Then run mover.

 

Or you can count how far in from the main directory your media files are and change the setting to that Nth.  And then run mover.  Either should work.

 

Another option would be to navigate to disks 2 and 3, creating "Media" folders on each of them.  Though I would just try the step above.

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...