Jump to content

Hyper-v nested vm status?


Recommended Posts



After trying to get hyper-v visual studio android emulator to run (Windows 10 VM with android studio)  i had no luck.

I''ve read through various post' s from 2017  saying this was not possible due to a bug in the linux kernel that was in use at that time (built into unraid 6.3.x ? )
So if i understood this correctly, it would maybe be possible when unraid switched to a newer linux kernel.
Have there been any progress on this subject?


I'm running unraid 6.5.3

I would like to run the hyper-v visual studio android emulator, due to intel HAXM is a no-go on a VM.

Link to comment

Nested virtualization support was removed due to problems with users that were running antivirus programs in their VM's. There may have been other problems with it enabled, but I'm not sure.


If you use the User Scripts plugin, there is a script to turn on / off nested virtualization.




You could also enable it manually with the following commands:


For Intel CPU's:

modprobe -r kvm_intel
modprobe kvm_intel nested=1

For AMD CPU's:

modprobe -r kvm_amd
modprobe kvm_amd nested=1


Link to comment

Thanks for your help.



I did use the user scripts provided in the post by gridrunner, and enabled it.
It worked!
At my first run i encountered an opengl-error(But i think this was related to me using windows rdp)

On the second go the emulator started up fine.

All these hours of trial and error, and the solution was this simpel :P.


I will continue to test and update this post, to see if i encounter any problems.


Edit follow up:

My hardware:

intel core i5-8500 6 core

DDR4 16gig 2666mhz

MSI GTX 1050 2 gig RAM


After two hours off testing this is my experience so far:

VM in use: Windows 10 VM   4core/4thread 8gig RAM nvidia gtx 1050 


With nested vm enabled:

Nearly all of the ram gets used up just be haveing windows sitting idel (92% used), and all the cores assigned has a load of 98/100 %.

To get both android studio and the emulator working i had to assign more RAM. This was expected as android studio likes haveing 4gig++ of RAM available and the target device that is getting emulated has 3 gigs of RAM.


When i increased the amount of RAM both worked, altough the performace was some what slow.



With nesting disabled:

Windows has an idle load of 0-1% cpu and uses 18% of RAM.


So i wonder if the overhead for haveing Hyper-v activated (In a nested configuration) is that much more resource demanding?


Does anyone who has passedthrough hyper-v via VMware seen such resource demands? 


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...