Jump to content

Issue with rsync from unraid to Dela Copy server (Windows)


Recommended Posts

I have been reading up on rsync for weeks now, and im still not sure whats going wrong. I am trying to backup a user share called "backup" to a Delta Copy server running on Windows 10.


rsync –av --delete /mnt/user/Backup rsync://

above is the line im running, and when i try to run it I get;

rsync: --delete does not work without --recursive (-r) or --dirs (-d).

even though nearly every rsync article I have found uses;

-a --delete

so if I change it to;

-ar --delete

I get a syntax error. And finally below is the output if I change it to;

-a -r -v --delete
 rsync –a -r -v --delete /mnt/user/Backup rsync://
sending incremental file list
rsync: link_stat "/root/–a" failed: No such file or directory (2)

However the weird part is that it does seem to be copying over the data...But considering that is is backing up critical data I don't want to just assume that's it working. something doesn't seem right and its more than likely something obvious.

Link to comment

Are you sure  you are running real a real rsync binary?

What does "which rsync" say?

What does "rsync --version" say?


Because it behaves as if it doesn't understand the -a (archive) parameter.


And -a is just a short form of  -rlptgoD which means that -a implies -r - the parameter it complained was missing for handling --delete.


Maybe the problem is that the other side - DeltaCopy - doesn't understand -a.

Have you tried to replace -a with -rlptgoD and seen if the program then will run as expected?

Link to comment

"which rsync" returned


and "rsync --version" returned

rsync  version 3.1.2  protocol version 31
Copyright (C) 1996-2015 by Andrew Tridgell, Wayne Davison, and others.
Web site: http://rsync.samba.org/
    64-bit files, 64-bit inums, 64-bit timestamps, 64-bit long ints,
    socketpairs, hardlinks, symlinks, IPv6, batchfiles, inplace,
    append, ACLs, xattrs, iconv, symtimes, prealloc

rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
are welcome to redistribute it under certain conditions.  See the GNU
General Public Licence for details.

I tried re-running the command as you suggested, one with "--delete" and another without, below is the output of both.

 rsync -rlptgoD --delete /mnt/user/Backup rsync://
rsync: -rlptgo\#357\#273\#277D: unknown option
rsync error: syntax or usage error (code 1) at main.c(1567) [client=3.1.2]
rsync -rlptgoD /mnt/user/Backup rsync://
rsync: -rlptgo\#357\#273\#277D: unknown option
rsync error: syntax or usage error (code 1) at main.c(1567) [client=3.1.2]


Link to comment

Are you doing a cut-and-paste or are you manually entering the commands?


Because the following printout seems to indicate the existence of additional characters between "o" and "D":

rsync: -rlptgo\#357\#273\#277D: unknown option
Link to comment


This topic is now archived and is closed to further replies.

  • Create New...