Jump to content

Various Minor Issues, PEBKAC?


Recommended Posts

I would like to lead off with a thanks for reading, and I will do my best to give all the information possible.



unRAID Version: 6.5.3

CPU: AMD 1700

Motherboard: Asrock Taichi x370

RAM: 2x16GB Dual-Channel Corsair LPX Vengence @3200mhz

USB: Sandisk Cruzer 16GB, not sure how old (potentially the problem?)

HDDs: Double Parity, 6x6 TB drives of mixed vendor/age.

Cache: 256 GB Sandisk SSD



(All up to date as of 07/31/18)

CA Auto Update Plugins

CA Cleanup Appdata

Community Applications

Dynamix SSD TRIM

Dynamix System Temperature

Fix Common Problems

Nerd Tools

Speedtest Command Line Tool


Unassigned Devices


User Scripts



(All up to date as of 07/31/18)






I have a few problems as of late that have made unRAID very difficult to use properly.


1) Any VM that I use VNC to connect to will lose it's VNC connection after a period of 10-30 seconds.  I then have to manually disconnect and reconnect the connection before it freezes back up.  I primarily use this on a Windows 10 VM that runs my Plex Media Server / mcebuddy / comskip combination that I use as a DVR.  This happens when I use RealVNC AND when I use a different VNC client and connect to my server's IP:port assignment.


My attempts at solutions:

Try using another VNC client

Change the VNC driver to every different setting

Opening ports on my firewall to allow VNC on my server between VLANs.  (I can try this one again, I may have set it up wrong)

Replace aging disks in the array

Adding an SSD cache with an old SSD drive


Note: I also get a locked screen when I access the web terminal from the GUI, or ssh from a terminal.  After a period of 10-30 seconds, the terminal hangs and I need to reboot it.  My CentOS VM that has a GPU passthrough does NOT hang during this time.


2) When I install Pop!_OS into a virtual disk, I can get as far as encrypting the disk.  After the image reboots, I get a black screen that is indefinite.  I am unable to look at the specific logs for this VM.  Any pointers would be helpful.  (Happens with both a GPU passthrough or VNC).


Other:  I had this CPU overclocked to 4.0GHz with 1.3v offset up to 1.37v for a period of about 3 months.  (Previously 3.6 at same voltage, but ran into thermal throttling.  After upgrading the case and installed a Corsair H110i brought the clocks up).  The temperature has stayed low this whole time and never got above 30-40C.  CPU utilization could max at most 4c/8t, and the other 4c/8t at approx 50%  I did this to improve the transcode times in my DVR VM, but have since set the BIOS to stock (except for changing the C6 state to disabled, and Virtualization to enabled, IOMMU enabled, as required for unRAID).  I ran a memtest for 2 passes (just 1 complete pass overnight, didn't want to leave it running forever) with no errors found.  The flash drive is a used drive from my collection, reformatted to use for unRAID about 3 years ago.


I suspect the flash drive is the culprit because I have tried everything else that I could think of or google up myself.  If anyone has any pointers it would be greatly appreciated.




Link to comment



Although I've waited this long to post something, I've been dealing with more and more errors for the past 6 months and I just can't deal with it anymore.  In an effort to troubleshoot my Plex VM I have to restart the VNC client every 20 seconds or so.  If anyone can help me, I would greatly appreciate it.

Link to comment

I’m not saying this is your issue, but I had a lot of problems connecting from a Vlan to my Krusader docker when my Vlan wasn’t configured properly.  I was constantly getting lockup’s.


This post helped to clear up my Vlan issues:



At any rate, this should help you to determine the proper setup of your Vlan’s.

Link to comment

@Limy  Much appreciated, I'm happy to have the help.  I changed some of my network settings, and I organized my pfSense rules to make changes a lot easier moving forward (assigned aliases, updates descriptions, etc.).  Although I do not see an improvement on the terminal or VNC client locking up, I do feel as though my setup is much cleaner.  I'm going to keep experimenting with the network settings, and see if I have to forward the VNC ports to my unRAID box or something to stop that from freezing.


Thank you again for the information.

Link to comment

I will definitely take a look at nomachine, right now I am trying to find a good encrypted alternative to VNC, I have many linux hosts so RDP won't always work for me.


But, after fiddling around with numerous settings I managed to fix my issues, thank you for pointing me in the right direction.  @Limy have a great weekend!


As I was changing settings in my firewall, updating rules, etc.  I ran into another problem (which was entirely an oversight on my end, and managed to fix it).  As I was troubleshooting this problem, I reset the state table on my firewall, which caused the lockups in both a virtual terminal running 'ping' endlessly, and my noVNC connection into my WIndows host (which makes sense because I killed the connections, but was eerily similar to the hangups that happened every 10-30 seconds before).


So, I think my issue was related to how I had unRAID interact with my VLANs.  I changed the IP address settings from 'Automatic' to 'None' on each VLAN.  I am assuming that I was causing broadcast storms and/or cross communication which was seriously impacting my network performance (At least on unRaid), which would be reflected with both the VNC connections and virtual terminal.  Since implementing this change (and others) I was able to completely eliminate my issues.


**My only residual issue is trying to install Pop_OS! in a virtual machine.  With or without GPU passthrough, after installing the operating system w/encryption I reboot the VM.  I am presented with a lock screen, and after popping in the decrypt key, the machine hangs indefinitely.  If anyone has any ideas, I would greatly appreciate it.


**I have every VM set up to CPU passthrough, not emulated.  I'm not sure if this is a pro or con.  [I understand the security risk involved of passing information between VMs, but I don't know of the CPU cost of emulating the processor, while searching for information I didn't find an answer].  I will be attempting to get the Pop VM set up today, so if I find a solution I will post here for posterity.

Link to comment

Glad I could point you in the right direction.


I and others will undoubtedly find that incorrectly setting up VLAN’s will cause those broadcast messages and cause the sort of issues you were facing.


My thanks goes to @ken-ji for initially pointing me in the right direction.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...